iPod Nano White Screen Issue (6th Gen)

Discussion in 'iPod' started by hogsdill, Apr 6, 2015.

  1. hogsdill, Apr 6, 2015
    Last edited: Apr 6, 2015

    hogsdill macrumors member

    Joined:
    Oct 22, 2007
    #1
    I have an iPod Nano (6th Generation) and recently it will only display a white screen after hitting the sleep/lock button. The main home screen will come back if I do a hard reboot by holding down the sleep button and volume down button. I can move through the touch screen just fine. Menus work like nothing is wrong. As soon as I hit the sleep button and then hit it again to wake it back up, the screen goes back to white.

    I can repeat the process of rebooting and the main home screen appears again.

    I've tried Apple's suggestion on this support page...
    1. Reset the device (press the Sleep and Volume Down buttons simultaneously until the display turns black—about eight seconds).
    2. When the display turns black, hold down the Volume Down and Volume Up buttons simultaneously until the device enters Disk mode.
    3. While the device is in disk mode, sync it to iTunes and try to restore.
    I can go through these steps, but I still have the same problem.

    Does anyone have any suggestions? I've replaced the display on other Nano's and could do the same for this one, but this doesn't seem to be a hardware issue since I can reboot it back to normal.
     
  2. hogsdill thread starter macrumors member

    Joined:
    Oct 22, 2007
    #2
    I purchased a new display from eBay and replaced it myself. This solved the problem. My guess is that there was a problem with the display's connection or ribbon cable.
     

Share This Page