iPod not fully showing up on USB 2 PCMCIA card

Discussion in 'iPod' started by Thomas Harte, Jan 19, 2006.

  1. Thomas Harte macrumors 6502

    Nov 30, 2005
    I have the older type of Powerbook G4 667 Mhz. To complement it I have one of the recent 30 GB iPods that can play video. I use OS X v10.4.4 and iTunes 6.0.2 - i.e. both the latest versions.

    The Powerbook only has USB 1.2 built in and the new iPod doesn't support data transfer via Firewire, so without extra hardware I am stuck with an incredibly slow data transfer rate. I have approximately 15 GB of music, which took something like 5 hours to download to my iPod. I would like to use the spare room for backups of other things I would not like to lose but am not sure I can bear it over the USB 1.2 connection.

    To that end I bought a plug-in PCMCIA card which provides two USB 2.0 ports. The specific model is the CBUSB220 from StarTech.com, which was explicitly listed at my retailed as OS X compatible. It has a little "power" cable that plugs into a normal USB port to provide power to devices plugged through the card.

    Now, a curious thing happens. When I plug it in my System Profiler does indeed identify that I now have a "USB High-Speed Bus" in addition to the 2 "USB Bus"s that were previously identified.

    If I plug my USB mouse into the PCMCIA card it is recognised and works flawlessly, as does my digital camera - although both are only USB 1.2 devices.

    If I plug my iPod in then the System Profiler recognises it and lists it as present on the High-Speed Bus (screenshot below). The iPod displays the "do not remove" screen. But after that nothing at all. iTunes doesn't recognise any attached iPod and it doesn't seem to be mounted in the Finder or indeed in /Volumes from the bash shell.

    Naturally I am curious as to why this might be and if there is anything I can do about it. I'm relatively new to the Apple realm, been here about a year now, but my guess is that on the whole if something doesn't just work then it isn't going to work at any point. My instinct is to test the PCMCIA with another USB 2.0 device, but I don't possess any.

    Anybody willing to take any guesses at anything I might do to make the iPod work through the PCMCIA rather than just slowly through the internal USB ports? Is there any way USB ports could work at USB 1.2 speed but not 2.0?

    EDIT: Forgot the picture. Here:
  2. mad jew Moderator emeritus

    mad jew

    Apr 3, 2004
    Adelaide, Australia
    Could it possibly not be getting enough power from the USB port? Is the PowerBook plugged into the wall adaptor? Even if it is, I'm not sure that'd help. :eek:

    Do you have anything plugged into other USB ports (not necessarily on this new card) at the same time?
  3. Thomas Harte thread starter macrumors 6502

    Nov 30, 2005
    Gosh, maybe I should just message you directly with my Mac problems from now on!

    Anyway, the only other thing plugged in was an optical mouse with built-in MMC/SD reader. Or at least it theoretically has a built-in card reader but that element of the thing doesn't work and I bought the mouse as a used second with that knowledge. The mouse element works perfectly and has done for several years.

    Although I have a severe dislike for trackpads, I have just tried unplugging the mouse with the iPod connected via the card. Still no change. I guess it might be worth a shot getting one of those multi-headed cables that plugs into the dock connector and then comes off with USB and Firewire heads. Hopefully the thing will be willing to take power from the Firewire and do data over the USB. It's a long shot, but...

Share This Page