iPod Photo - Won't Turn On

Discussion in 'iPod' started by the-boognish, Apr 24, 2007.

  1. the-boognish macrumors newbie

    Joined:
    Apr 24, 2007
    #1
    I have had an iPod Photo for just over 3 years. The other day, it acted strangely while it was playing. It would play fine, but the screen would freeze. Music was playing just fine in a playlist, but no ability to navigate. It could be fixed by just restarting the unit, but it happened 2 or 3 times in an hour.

    Then, a day or two later, I got a Sad Mac when I turned it on, then nothing. It will no longer turn on. I've hooked it up to the wall adapter, and USB, but nothing. All of the fixes on the forums I've read assume the iPod will turn on, and mine will not.

    I know that the battery can go out, and I have used it heavily for 3 years, so it wouldn't surprise me that I need a new battery, however, I want to get some opinions before I go down that path. I would hate to buy a new battery only to find out it doesn't solve the problem.

    Is anyone familiar with what happens when a battery fails? Any other ideas of what may have gone wrong? I've tried the "smacking" technique, and all the other fixes I could find. The iPod never made any strange noises, and only gave me the error one time before shutting off for good.

    Thoughts?
     
  2. Fearless Leader macrumors 68020

    Joined:
    Mar 21, 2006
    Location:
    Hoosiertown
    #2
    not the battery, because you can run it off a charger.
    sounds like something horrid happened, you'll probably spend more time\energy\money trying to fix it than just getting a new one. 30gb 249$ us longer battery and plays video.

    couple of questions though.
    it does nothing in response to any of the fix's?
    it doesn't charge when plugged in?
    does it smell funny, like burnt plastic?

    my 3rd still works but does what your did, but i did muck around in it...
     
  3. the-boognish thread starter macrumors newbie

    Joined:
    Apr 24, 2007
    #3
    Nothing works on the fixes because it won't turn on. All of the fixes talk about turning it on and then performing some steps. I can't get the thing to even power up.

    No, it doesn't charge when plugged in, and I've tested it on my car charger, usb and wall. It was charged when this problem happened.

    Nope, no smell of burnt plastic. Had it in a bag, got it out, turned it on, Sad Mac, it turned off, and now...nothing.

    Good to know about the battery. At least I can avoid wasting my time on that.
     
  4. Fearless Leader macrumors 68020

    Joined:
    Mar 21, 2006
    Location:
    Hoosiertown
    #4
    have you tried flipping the hold switch on and off then pressing either the play and select/play menu/ or menu select (its one of those cant remember which.)
     
  5. the-boognish thread starter macrumors newbie

    Joined:
    Apr 24, 2007
    #5
    Yeah, tried both of those things last night. Its actually menu/select I think, but I tried both. Nothing.

    I'm just trying to get anything to make it work. Sure I can get another one, but not right now. It'll be several months. This iPod is my baby, its been everywhere with me, and its hard to let go.
     
  6. triobot macrumors member

    triobot

    Joined:
    Apr 3, 2007
    Location:
    Milton Keynes
    #6
    lol? don't get attached to a piece of technology, its always changing...

    Hmmm try opening it up and see what's actually burnt... Maybe a wire's been shorted and burnt or sumit... You might have to get a new mother board for your pod...
     

Share This Page