iPod problems --can't find solution anywhere!

Discussion in 'iPod' started by altogether, Aug 9, 2007.

  1. altogether macrumors newbie

    Joined:
    Jun 12, 2006
    #1
    On my Macbook I've been having the same problems with both my 30g iPod and 2G Shuffle. When the iPod is syncing at some point (in an especially long sync and sometimes even a short one) I will get the message "disk cannot be read from or written to" or the "ipod was disconnected without ejecting" both causing all my files on the ipod to become corrupt and in most cases the iPod wont turn on until restored. Now, I thought this was a problem with my Ipod itself until...

    My Shuffle does the same thing! I'll be dragging files to it and you know how it stops a second to mount and load the files? They will just show up on there immediately and then give the error message like before. Upon plugging it back in the files that went on there faster than normal are not there and I have to restore it to get it to work again.

    I've tried everything I can think of. Using different cables, trying disk repair. It's almost like theres something wrong with my USB ports... I haven't found very many people who have had the same problem online or atleast people who've found a solution to it. I really don't wanna call Apple.
     
  2. Analog Kid macrumors 601

    Analog Kid

    Joined:
    Mar 4, 2003
    #2
    I think you need to call Apple on this one... I think you may be right about the USB ports. Other things to try first, if you want to, is make sure the problem happens with all the USB ports, and see if other USB devices have the same problem.
     
  3. ds252 macrumors regular

    Joined:
    Aug 6, 2007
    #3
    The same thing happened to me on a PC with a 5G 60 GB and i just sort of waited it out and it went away, i didn't do anything special about it.

    What would happened with me was that it would load about 1/4 of the songs then just stop and say it's disconnected, sometimes allowing me to play those songs and sometimes not.

    I dunno if this is your problem but it sounds similar.
     
  4. altogether thread starter macrumors newbie

    Joined:
    Jun 12, 2006
    #4
    yeah that's pretty much like my problem. Once I got my entire library onto it without it freaking out. I figured it was okay, but one I synced my podcasts it screwed up again.
     
  5. ds252 macrumors regular

    Joined:
    Aug 6, 2007
    #5
    I would just keep trying for a few days if you have the patients and if it still doesn't work call up apple and explain the problem to someone there.
     

Share This Page