Discussion in 'iPod' started by Fallen Royalty, May 9, 2009.

  1. Fallen Royalty macrumors newbie

    May 9, 2009
    My 30G iPod Classic (5th generation) is stuck in perpetual recovery mode. I plug it into iTunes; it tells me to Restore; I click Restore; iTunes "restores" it; then it brings me back to the exact same "this iPod needs to be restored" message.

    I decided to Google the problem and found many, many iPod users who have the same problem - the majority of them 5th generation Classic owners. Anyways, the most common fix was to change the Drive letter associated with the iPod. This was because Windows (Vista user here) was confusing the iPod with another drive that uses the same letter. I tried changing the letter. First to "Z", then to "S". No dice.

    The next option was to go into Disk Manager or My Computer (really anywhere in Windows Explorer that lets you view your disks), right click the iPod, and "Format" it, i.e. wipe all data. I tell it to Format. A bar comes up. It creeps ever so slowly. Finally after two hours (literally) the bar fills... and Windows tells me it can't Format the drive.

    I'm stuck. I even checked the official Apple site. First it gives me the drive letter fix, then if that didn't work it told me to Format it. Neither solution is working. Anyone else who has encountered this problem? Anyone who knows how to fix it?
  2. rfasano806 macrumors newbie

    Sep 22, 2009
    how are you doing? my name is Ryan and i am haveing the same problem with one of my i pods. have you found a way to resolve the perpetual restoration problem?
  3. esper macrumors newbie

    Jan 18, 2010
    i too. same problem and have searched and cannot find answers.. help!!!! please desperate..
  4. usermars macrumors newbie

    Jun 5, 2010
    Ipod in perpetual restore: a possible solution for Mac users

    Hope this might help you out there.

    I had my Ipod 30 G stuck in perpetual restore/recovery (on a macbook). I did everything to get it up again. All the things already written above like disk check and reformatting. I even went to my Linux computer and was able to write all the usual files like IPod-Control to the Ipod. Also tried a Windows computer. Nothing worked, the Ipod would stay in perpetual restore. Then, after about 4 hours, I thought lets try this thing I read about and I didn't believe it would work: open the Ipod into Itunes as superuser/root (on a macbook). I first did the usual restore as a normal user. Then I logged in as root/superuser. Now the Ipod immediately came up in a normal way and everything worked fine from then on. I logged in as a normal user and everything worked fine. A very strange problem as I have also superuser privileges as a normal user. The Apple developers should look into this! Greeting from Holland.

Share This Page