ipod touch 16gb not charging

Discussion in 'iPod touch' started by balwx, Dec 19, 2008.

  1. balwx macrumors regular

    Joined:
    Aug 22, 2007
    #1
    greetings folks. my son grabbed a hold of my 1st generation touch & put his mouth on the bottom where the synching cable goes. Now my touch doesnt charge. :( Before he grabbed it, it had a full charge. Damn.

    I have tried holding the two bottoms for 10 seconds & the other steps on the apple web site. Itunes doesnt see the touch so I cant restore. We I try to charge it from my macbook, I can see the large battery & a small sliver of red with the charge lightning bolt. But it just wont charge.

    Does anyone have any last resort tips/ tricks for me? Or do I just have to get the iphone & get it over with?

    Thanks!:cool:
     
  2. mkrishnan Moderator emeritus

    mkrishnan

    Joined:
    Jan 9, 2004
    Location:
    Grand Rapids, MI, USA
    #2
    The only major thing to suggest at this point is get something with which you can clean the inside of the dock port and alcohol swab it.
     
  3. ThunderBull4 macrumors 6502

    Joined:
    Jul 28, 2008
    #3
    I would suggest leaving it for a couple hours and letting it dry, then try again.
     
  4. balwx thread starter macrumors regular

    Joined:
    Aug 22, 2007
    #4
    Thanks folks for responding. This happened a few days ago & its still not charging. I will try an alcohol swab. If not, i'll be buying another one.
     
  5. ibridget macrumors newbie

    Joined:
    Dec 4, 2008
    #5
    This may sound odd but try spraying it with a can of compressed air? Might help dry it out in there.
    Also leave the device on, let it completely drain, then charge it. I have an external charger, not via the pc and usb cable.It plugs into the wall then you use the usb cable and hook that in from the charger to the touch. Once it was completely drained and recharged, then I was able to hold down the buttons and do the restart and reformat steps.
    Looks like jr has his own secret weapon there, huh? Baby saliva lol..stops em dead. ;)
     
  6. balwx thread starter macrumors regular

    Joined:
    Aug 22, 2007
    #6
    Thanks for the suggestions. I tried the alcohol method and it worked, I was able to get the touch going again! Great! The battery is showing full charge (like before the little guy got his mouth on it). Now my problem is that the 'home button' isnt working, damn. I tried to restore the touch through itunes, & synched my last backup. 'home button' is isnt working. Oh well....
     

Share This Page