iPod touch 1G 2.2.1 WILL NOT jailbreak

Discussion in 'iPod touch Hacks' started by tmad40blue, Sep 7, 2009.

  1. tmad40blue macrumors newbie

    Joined:
    Apr 27, 2009
    Location:
    Ann Arbor, MI
    #1
    Hello all, I have a 1G iPod touch with firmware 2.2.1. Whenever I open QuickPwn to being the jailbreaking process, QuickPwn just sits there. It says "Please connect your device, we'll test it etc.", and I do connect my iPod. The iPod begins to charge, and it is recognized perfectly in iTunes (I can copy music to it and everything). But QuickPwn acts as if nothing happened. So I tried redsn0w 0.8. Well, it doesn't like my 2.2.1 firmware file, even though I've downloaded it 5 times from 5 different locations (all reliable). I gave up on that. Then I tried redsn0w 0.3. It guides me through kicking the iPod into DFU mode, and gives me the "DFU MODE SUCCESSFUL" message. Then it says a few more things, and I get stuck at "Waiting for reboot..." This message never goes away. I've tried unplugging and plugging the iPod back in, as the program says to do, but nothing else happens. I've left the iPod for an entire hour with no results - I eventually just have to force reboot the iPod again. I've tried restoring, I've tried quitting iTunes Helper, I've tried everything I can think of. Anybody have any insight? Thanks!
     
  2. rrm74001 macrumors regular

    rrm74001

    Joined:
    Nov 11, 2008
    #2
    First, make sure that when you are using RedSn0w (Not sure if the latest v0.8 supports the older 2.x firmwares. You might have to find an older version.) that you do a DFU restore to a STOCK non-jailbreak firmware (do not sync any music or anything yet). Then in RedSn0w, tell it the location of your STOCK non-jailbreak firmware. When it says, "Waiting for reboot...", unplug the iPod for 10 seconds, and plug it back in and it should be good from there.

    If it still does not work, the easiest thing would be to update to 3.0 and use RedSn0w 0.8.

    QuickPwn is kind of old and perhaps Apple has updated Mac OS X (are you running Snow Leopard?) and iTunes to block QuickPwn from doing it's thing. There is PwnageTool but I find that only works if you are jailbreaking a firmware for the first time.

    P.S. I just re-jailbreaked my iPod Touch after I installed Snow Leopard, so I know for sure RedSn0w 0.8 is currently compatible. Is there a reason you are sticking to 2.2.1?
     
  3. tmad40blue thread starter macrumors newbie

    Joined:
    Apr 27, 2009
    Location:
    Ann Arbor, MI
    #3
    All of the firmware I have used has been STOCK FIRMWARE. Not jailbroken, not custom. Even so, redsn0w DOES NOT accept it. It says "Unable to recognize specified IPSW" on EVERY firmware file I've downloaded.

    When redsn0w 0.3 says "Waiting for reboot..." I have done EXACTLY as you have said. Unplugged the iPod for 10 seconds, and plugged it back in. NOTHING HAPPENS AT ALL. redsn0w doesn't react and my iPod still has a black screen.

    I can't update to 3.0 because I don't have an iTunes account. So that's not possible.

    I'm running Leopard 10.5.8 and iTunes 8.1. iTunes helper is not running when I'm attempting to use redsn0w.

    I've tried using PwnageTool but it also says my firmware files are bad. I haven't jailbroken my iPod since before 2.0, so I don't think the "first time" thing would be a problem. Besides, it's been through multiple restores since then.

    Again, I'm sticking to 2.2.1 because I can't buy 3.0.

    Sorry that my situation is so complicated. D:
     
  4. dagored macrumors 65816

    Joined:
    Sep 18, 2007
    Location:
    Florida
    #4
    rrm74001:

    Then in RedSn0w, tell it the location of your STOCK non-jailbreak firmware. When it says, "Waiting for reboot...", unplug the iPod for 10 seconds, and plug it back in and it should be good from there.


    Thank you. Why isn't this in the instructions. I have hacked my 1st gen Touch since jb first arrived on the scene.

    Been out of the loop since 3.0 updated, got into collecting flashlights, don't ask.

    I know I was not doing anything wrong, but after 5 minutes of "Waiting for reboot...", I searched, found your comment, and I am now syncing my JB 3.0 Touch.

    Thank you again.
     
  5. aztecman macrumors newbie

    Joined:
    Sep 12, 2009
    #5
    I was googling for something else when I stumbled on this site and post.

    Incidentally I jailbreak (jailbroke? :)) 2 iTouch last night. I did one with QuickPwn and another with RedSn0w.

    If I have not misunderstood your post, you did not mention that had restore your firmware as the iniitial step.

    The 2 iTouch were both 2G with 2.21 firmware. I restored both in iTunes to the iPod2,1_3.0_7A341_Restore.ipsw

    When I did with RedSn0w, I had also had the same problem that you encountered. The process stopped when the rebooting message came up.

    I unplugged the iTouch from my computer and did a reset. Then I restart the RedSn0w process again. The 2nd time the process went smoothly until before the copying of the ramdisk finishes when RedSn0w crashes and closed. But the jailbreak process continued and everything was succesfull.

    No problem with using iTunes 9 and installing any IPAs.
     

Share This Page