iPod Touch 1G will not restore

Discussion in 'iPod touch' started by bootstrap, Dec 4, 2009.

  1. bootstrap macrumors newbie

    Joined:
    Dec 4, 2009
    #1
    Apologies as this has been asked before, however I know I have a good go at fixing this and reading the posts etc, I believe I have a unique problem.

    I have bought a secondhand 1G Touch which was pitched as 'broken'. It is in perfect physical condition and powers up as if it is in "recovery mode" - NOT as "DFU mode". Recovery mode I indentify by the "iTunes and cable" on screen; DFU mode would remain black.

    iTunes says the device is in recovery mode, and must be restored. I have tried this many times with several versions of firmware, and tried holding the 'home' before plugging in the usb to confirm it is in recovery mode. The logo remains visible until you try to restore.

    Everytime you try to restore it unpacks the firmware, prepares the iPod which I think is loading a small bit of boot code, and then the device disconnects (the windows USB plugged sound). Just prior to this sound, very briefly I believe there is an Apple logo with a spinning white disk. From this point iTunes and any other program I try waits for the iPod to reboot - which it never does - remaining black until you unplug and plug the usb back in.

    I have tried to put it in DFU mode but I cannot. Step 1 is always "turn the device off". It is always off and unresponsive, and only comes on when plugged in. No combo of buttons held down makes any change, except for holding home to get recovery mode. When you unplug the usb the device goes black again, and cannot be turned on.

    I have also used ZiPhone to put it in DFU mode, looks sort-of the same as recovery except the background is more blue than black. iTunes still fails, as do all the other programs (blackra1n, redsn0w, QuickPwn just crashes when the iPod is plugged in). iRecovery can't see it, so neither can 1Click.

    I've getting a little over it now, so ANY help would be great. I'm sure the key is DFU mode, but how do I do that when I have no control over if it is on or off? My fingers are very sore from holding those buttons down!

    Cheers guys and thanks heaps for your time and patience.
     
  2. MrBrekke macrumors 6502

    MrBrekke

    Joined:
    Oct 1, 2009
    Location:
    Norway
    #2
    this might help:

    plug it in so the device is on. then hold home and power button down for 10 + sec. this should turn the device of. now try to get it in DFU mode. power button 5 sec, keep holding and press home and hold for 10 sec. release power button but keep holding home button for 20 sec.

    voila now you have a device in DFU mode and i would suggest using the old quickpwn. if that don't work you can use the other tool from Dev Team.
     
  3. bootstrap thread starter macrumors newbie

    Joined:
    Dec 4, 2009
    #3
    Awesome thanks for the reply!

    I tried this straight away but no luck, the device will not turn off. The Touch is seems to stay in recovery mode whenever it is plugged in (shows the "connecting to iTunes logo). iTunes starts when it is plugged in, says it is in recover modey, but fails on update.

    I have also tried (before I posted) on another latop that was not allowed onto the internet. Same result.

    One final thought: perhaps one of the buttons is stuck/not working? Pulling it apart seems a but extreme but if it's something like a broken power button I could fix that.

    Thanks again dudes
     
  4. bootstrap thread starter macrumors newbie

    Joined:
    Dec 4, 2009
    #4
    UPDATE:

    After exhausting almost all available software tools and finally reading theiphonewiki.com I was sure there was a 'hardware' problem preventing DFU mode. So I popped the back off the Touch and tested the power switch.

    Thw switch was fine, but someone has messed with the battery wiring. All the wires are red and there is sellotape around them. The soldering and general workman ship is poor, and I think the main battery line is not connecting to the battery. It appears to be the original battery, hard to tell really.

    I tested the voltages to the logic board, with and without the usb cable: From outside edge of the case (black wire?): 0V, +0.4V -0.4V; 0V +4.2V +2.1V.

    So it seems the battery is not connected. I'll take it to work at some stage and try to patch the wiring, see if that helps.

    Does the Touch's behaviour I describe agree with what a Touch does without a battery? I mean, if anyone's ever tried to run one without a battery...
     
  5. bootstrap thread starter macrumors newbie

    Joined:
    Dec 4, 2009
    #5
    UPDATE 2:

    I have tried fitting an old cell phone battery to power the Touch and I can confirm that without a battery a restore cannot complete. The device has to reboot while connected to the usb, and without internal power it will not boot.

    Once I had fitted the battery the phone completed a restore easily, no DFU mode needed.

    The good news for me is that iTunes reports that it is a 16GB device! (the back cover says 8GB, dodgy) The bad news is that the touch screen does not seem to work. I didn't play with it too much as there were wires and a battery sticking out the back, but the "slide to unlock" would not work :(

    I will perserve with this and try to replace the touch screen. This looks very difficult but possible. Good exchange rate to the US ATM so the parts are not very expensive.

    Thanks for all your help, I'll post once I've received the parts and had a go at replacing the screen.
     
  6. bootstrap thread starter macrumors newbie

    Joined:
    Dec 4, 2009
    #6
    UPDATE 3:

    Upon closer inspection the logic board ribbon cable is damaged, almost cut right through at the logic board edge. This explains why the digitiser and the power button were not working (and I guess also the WiFi too if I'd got that far).

    So a bit of a dissapointment, does anyone know of this ribbon cable can be replaced? Or is it a whole logic board change now?
     
  7. xMastemah macrumors member

    Joined:
    Dec 6, 2009
    #7
    You'd be lucky to find a ribbon cable by itself...for anything really. Typically they are only sold to manufacturers for certain parts (e.g. the logic board, a laptop touch pad, etc.) and whole part replacement is in order, TYPICALLY. You'd have to do some searching for this one as I'm not 100% sure, but if you can't find your desired cable, this is probably why.
     
  8. bootstrap thread starter macrumors newbie

    Joined:
    Dec 4, 2009
    #8
    Looks like you're right about the ribbon cable, certainly not available as a spare. I was hoping to find someone selling a dud logic board or something and salvage a cable from that, but no luck. People probably just biff their duff logic boards when they replace them.

    I'm gonna pull the plug on this one for now, and just keep an eye out for a 8GB 1G with a smashed screen. I device I have is in excellent condition front and back, so a new logic board and battery is all I need.

    I don't care about the storage capacity as I plan to use this as a HTPC remote control.

    Thanks for your input
     
  9. kAoTiX macrumors 6502

    kAoTiX

    Joined:
    Oct 14, 2008
    Location:
    Midlands, UK
    #9
    I have 1G parts I don't use and only kept incase of a repair job that required something. The iPod was initially water damaged as far as I know.
    Wouldn't turn on so I stripped it down and couldn't get it to work at all.

    There is a weird coating along part of the logic board, looks like it got wet then dried out. The battery is still attached and I have all parts.

    If you want it you can have it.
     
  10. bootstrap thread starter macrumors newbie

    Joined:
    Dec 4, 2009
    #10
    That would be awesome if you'd send me that.

    I live in New Zealand, I've never ordered anything from a 'person' overseas before, so I have no idea how to pay for stuff and shipping etc. The best way to pay would be an overseas currency 'swift' transfer, at least I think that's what it's called.

    If you give me a price you're happy with and a method to transfer the cash I'd definately appreciate that. My email is bootstrap18@hotmail.com if you send me something to that I'll replay from my 'real' email account.

    Thanks!
     

Share This Page