Ipod touch 1st gen help needed

Discussion in 'iPod touch' started by atugwell82, Jun 7, 2011.

  1. atugwell82, Jun 7, 2011
    Last edited: Jun 7, 2011

    atugwell82 macrumors newbie

    Joined:
    Jun 7, 2011
    #1
    Hi i just bought an ipod touch 1st gen off my mate and it had 2 round ink marks at the top of the screen but other then that it worked fine. so i bought a replacement lcd screen.and i atempted the repair myself.while taking the battery off i split the silver caseing of the battery a little bit but it all came off ok so i managed to get the old screen out and put the new one in and when i turned on the ipod nothing happened but if i plug it into the pc it still connects fine and shows everything thats on there.so i decided to put the old screen in to see if the new screen was a dud and the same thing is now happening nothing at all on the screen and i cant seam to work out what ive done wrong.any help would be great. also as im a noob at this i just wanted to know if when testing the lcd screen does it matter if you dont put all the screws back in?
     
  2. WLS macrumors 65816

    Joined:
    Jul 10, 2008
    #2
    that's more effort than most of us would have done for a Gen1. It sounds like the problem is the ribbon connector from the screen or the connector for the ribbon to the motherboard. You can try cleaning that part and reattaching it.
     
  3. atugwell82 thread starter macrumors newbie

    Joined:
    Jun 7, 2011
    #3
    ty for the quick reply ive also just noticed that the black wire connecting the battery isnt connected lol but i would have thought is wouldnt power the ipod at all but its just the screen that doesnt seam to be working oh well will soilder it bk on and hope its the only problem.
     
  4. atugwell82, Jun 10, 2011
    Last edited: Jun 10, 2011

    atugwell82 thread starter macrumors newbie

    Joined:
    Jun 7, 2011
    #4
    ok i put the battery back on but i have now noticed that somthing is missing from the top left hand corner there is just a tiny bit of ribon and it isnt attached to anything but when i look in pictures it shows this ribon connected to a small bord that isnt in my ipod touch 1st gen.sry its such a noob decription but im still learning lol would this stop the lcd screen from working? as when i took it appart i dnt even remember seeing the part missing in there and the lcd screen did work just had 2 round ink marks on it. any info would really help.i know its prob stuped going to all this trouble for a 1st gen but to be hounest i really enjoy trying to fix things lol.
     
  5. pezzulo macrumors newbie

    pezzulo

    Joined:
    Jun 10, 2011
    Location:
    selkirk, NY
    #5
    just get a new one

    you should really get a new one. they make a new version ipod every year. the 4th is out. that means your ipods four years old. its gunna be hard not to encounter problems
     

Share This Page