iPod touch 1st gen restore error 20.

Discussion in 'iPod touch' started by raysfan81, Sep 5, 2010.

  1. raysfan81 macrumors 6502a


    Oct 6, 2009
    North Carolina
    I was trying to downgrade my touch to firmware 2.2.1 and it keeps giving me error 20 and I have the screen looking like this attached image. Help me please! :(

    Attached Files:

  2. kaiserkid macrumors newbie

    Apr 9, 2013

    I am having the same problem. Bought the iTouch on ebay, they didn't state what the problem is but from what I can tell someone attempted to jailbreak it and failed.

    It first did error 9 at the apple store, apple told me I was "SOL" and I could buy an entire new phone for the small price of $270 with the "generous" 10% discount they were giving me.

    Now after searching forums, I've got it to do error 20...not sure if this is better.

    Apple knows how to fix this but refuses to help unless I give up and buy a new device.

    Has anyone been able to fix this problem? I'm willing to use any program that could fix this.
  3. The13thDoctor macrumors regular

    Mar 12, 2010
    I'm not sure if this applies to iPhone OS, but I think the signing period for the firmware has long passed and since you're on a jailbroken device, it doesn't let you restore anymore.
  4. Bear macrumors G3

    Jul 23, 2002
    Sol III - Terra
    In general Apple will only let you install the latest firmware for the device in question. You should be able to restore it to the latest firmware it supports. I am curious as to why you want to downgrade it.

    Have you tried following iOS: Unable to update or restore and make sure you're trying to install the latest firmware for the device.
  5. kaiserkid macrumors newbie

    Apr 9, 2013

    Have also tried this and to no avail. I'm on a never ending loop of error 9, error 20, and sometimes will get the "Could not be restored the device cannot be found".

    The iTouch is in an never ending cycle of this. Apple techs haven't been any help. Does anyone else have any suggestions? I've tried several "repair programs" for iTouch and they haven't worked. I've uninstalled and reinstalled iTunes so many times I can't count.

    Any suggestions would be appreciated.
  6. pod5g macrumors regular

    May 15, 2013
    Why do you want to downgrade it? The latest version available for the original iPod touch is 3.1.3, which has been jailbroken.
  7. IpadSC400 macrumors 6502a


    Feb 7, 2013
    A mile high
    My iPad was jailbroken and it was able to restore...:confused: It's version software 5.1.1

Share This Page

6 September 5, 2010