iOS iPod Touch 2.1 Software Update

CarlosH

macrumors member
Original poster
Apr 9, 2008
76
8
San Francisco, CA
Anyone having troubles with this update? I use my iPod Touch as a development device, and now I cant debug, the application gets installed, but debug fails. Also, the "UIPrerenderedIcon" key in the info.plist is not working, now my icon has the shine.
 

TripleJ

macrumors regular
Jul 30, 2008
128
0
You need to use the new iPhone SDK build 9M2517 which was just released today :) Otherwise it won't work. Just download it from the dev centre!
(on a sidenote, i really wish they'd let us update it instead of having to download the full install)
 

CarlosH

macrumors member
Original poster
Apr 9, 2008
76
8
San Francisco, CA
You need to use the new iPhone SDK build 9M2517 which was just released today :) Otherwise it won't work. Just download it from the dev centre!
(on a sidenote, i really wish they'd let us update it instead of having to download the full install)

Thanks, I never pay attention to that part. Well 1.3gb to download.
 

TripleJ

macrumors regular
Jul 30, 2008
128
0
Do we have to add the certificates to xcode again after we install the new SDK?
I'm thinking it'll transer over as long as you install the new version on top of the old one without uninstalling :) Your certificates are in your keychain thingamajiggy and therefore shouldn't be affected... (*fingers crossed*)
 

drivefast

macrumors regular
Mar 13, 2008
128
0
:eek: one point four gigs?? :confused: i hope this thing is not on its way of getting to microsoftic size.
 

nottooshabby

macrumors 6502
Jul 12, 2008
353
40
I'm thinking it'll transer over as long as you install the new version on top of the old one without uninstalling :) Your certificates are in your keychain thingamajiggy and therefore shouldn't be affected... (*fingers crossed*)

But you have to drag them onto the x-code project....hopefully this update doesn't mess that up.
 

CarlosH

macrumors member
Original poster
Apr 9, 2008
76
8
San Francisco, CA
You don't need to reinstall any certificates or anything.
I was having troubles with the certificates, it was telling me certificate 4xxx-xx was not correct, so I went to my build options, and re-assigned my development certificate. Now everything is working fine, except for the "UIPrerenderedIcon" key.