Ipod touch 2g errors

Discussion in 'iPod touch' started by bilbous, Jan 29, 2011.

  1. bilbous macrumors newbie

    Joined:
    Jan 29, 2011
    #1
    I will get straight down to the problem and see if anyone can be of assistance.

    A friend popped his Ipod touch 2g (16gb) into me to take a look at as i do a lot of repairs to these. He had of course had a go himself first and failed miserably.

    Anyway before repairing his digitiser I plugged it into the pc and itunes picked it up but said it was in recovery mode.
    I decided to let it recover but got an error 21. I have since tried a whole host of things but I end up getting error 21 or error 1601.

    The ipod seems to be stuck in a mix of dfu and recovery modes. I have looked at IREB and others but no joy.

    Also, tried some different things, redsnow will go through the motions install all the info etc but then when it does the final reboot it sticks at a white screen.

    Any help appreciated but i think this one is ready for the ipod grave.

    He does not have any backup info on his computer either.
     
  2. saving107 macrumors 603

    saving107

    Joined:
    Oct 14, 2007
    Location:
    San Jose, Ca
    #2
  3. IpadSC400 macrumors 6502a

    IpadSC400

    Joined:
    Feb 7, 2013
    Location:
    A mile high
    #3
    I have an ipod that does the same thing. Water indicator is white like it should be.:confused:
     

Share This Page