iPod Touch 2g stuck on Apple Logo after restore.

Discussion in 'iPod touch' started by sean48611, Jul 2, 2012.

  1. sean48611 macrumors newbie

    Joined:
    Jul 2, 2012
    #1
    Well, I have searched to the ends of the internet in trying to fix my iPod touch.

    I have been entering my iPod into DFU mode and then restoring, and then
    my iPod restores as normal, takes a long time but it eventually restores, but after
    being restored it just reboots and gets stuck back at the apple logo.

    I have used sn0wbreeze ipsw's, I have tried downloading and using other firmwares, and I have tried using the latest itunes default restore but nothing seems to work.

    Any suggestions?
    (and no, I have never jail broken my iPod)
     
  2. aarond12 macrumors 65816

    aarond12

    Joined:
    May 20, 2002
    Location:
    Dallas, TX USA
    #2
    Just a long shot... try another cable. I used a third-party cable once to restore my iPhone, and it ended up bricking it.
     
  3. srh76 macrumors newbie

    Joined:
    Jul 6, 2012
    #3
    I'm having the same trouble. I bought an ipod touch 2g 8gb off ebay thinking it should be simple enough to restore. I also seem to be only able to get it to do anything when it's plugged into the charger or the pc. I've tried all different firmwares and it always reboots as far as a flashing apple logo. It's driving me mad.
     
  4. srh76 macrumors newbie

    Joined:
    Jul 6, 2012
    #4
    *Update*

    I've been playing around with the ipod for a couple of days and have had a breakthrough of sorts. I connected the ipod to my pc with itunes running and got it into recovery mode (which I'd done a few times before, along with DFU mode). But instead of doing a restore, I quickly unplugged it and connected it to my wall charger and let it charge fully. Well blow me down, when I plugged it back into the pc it appeared in itunes as a new ipod! Unfortunately my excitement was short lived as I unplugged it and noticed the battery level dropping very quickly. I decided to shut it down and turn it back on to see what would happen and it's gone back to flashing at the apple logo.:confused:

    Anyway, it could be a bad battery, or something more sinister. The main thing is there was progress. I'll keep plugging away, but not sure more can be done without spending time/money on an already oldish ipod.
     

Share This Page