IPod touch 2g stuck on apple logo

Discussion in 'iPod touch' started by iMacMan1, Feb 25, 2011.

  1. iMacMan1 macrumors newbie

    Feb 25, 2011
    I got this itouch 2g (mc model) from a friend for free (the screen is cracked). I turn it on and I see the connect to itunes screen. I connect it to itunes, it had to be restored so I did and the itouch worked fine. But, when the battery died I tried charging it and the apple logo came up instead of the charging screen. I waited for 10 min it turned off and on again with that screen. after 10 min the screen went blank and when i turn on the itouch, it wasn't even charged! it was still on low battery. I tried restoring it on itunes but, when I turned it on the freakin apple logo was on again. It would stay there until the battery died. When I try connecting it to itunes, the apple logo comes up and doesn't connect to itunes. SO, i put itouch in recovery mode, restored it..AGAIN, and the apple logo would stay, even after the restore. please I need help with this and idk what 2 do!!! :confused:
    P.S the itouch used to be jailbroken but, i guess that gets removed after restoring it on itunes.
  2. neim81094 macrumors newbie

    Feb 26, 2011
    Why dont you wait to see what happens nxt? I mean if the ipod isnt crashing and looping then it is loading a itouch 2g takes about a min to reload i would let it do its thing, and keep it plugged in so it won't die while booting it could be a dead battey, give it time give it like ten minutes if the problem still persists then idk what the problem is besides a hardware malfunction
  3. iMacMan1 thread starter macrumors newbie

    Feb 25, 2011
    yeah i just tried that. keeped it plugged it the charger, the apple logo showed up and was there like FOREVER! even after 10 min. It turn off and on again many times and then the screen went blank. I unplugged the itouch, turned it on, and guess what? it was never charged, and was still on low battery even when I keeped it plugged it for 2 HRS. I tried using itunes and the usb charger to charge the device but, whatever I freakin do it sames on that freakin apple logo screen! should I restore it? I bet I can try restoring that device and every time the restore is done. The apple logo screen would just say on until the battery dies. I don't think it's loading cause an itouch doesn't load the springboard for over 2hrs.
  4. neim81094 macrumors newbie

    Feb 26, 2011
    Then i guess it is a hardware malfunction sorry buddy if you figure it out other then the fact that it wasnt a hardware error tell me
  5. brownstonemr macrumors newbie

    Feb 10, 2009
  6. iMacMan1 thread starter macrumors newbie

    Feb 25, 2011
    yeah i remember reading that thread the other day. Just tried that yesterday..unfortunately, it remained stuck on the apple logo:(
    oh yeah, i just remembered when the itouch was working, the wifi wasn't working properly so i reset the wifi network settings and then that's when the itouch was first stuck on that logo
  7. snah113 macrumors newbie

    May 13, 2012

    Bro, i just have the same problem right now...hope you still have the ipod...or maybe u find it useful....just charge it for at least 1 hour, by power, not by computer...then plug it into ur computer...then hold the home botton for at least 3 minutes...the screen turns white and still you keep holding it...then the apple logo will appear and finally the connect to itunes icon will appear...restore and update...that-s it...
    hope u find it useful

Share This Page