iPod touch iPod Touch 2G won't restore... even from DFU

TrevorB

macrumors newbie
Original poster
Nov 28, 2009
9
0
I know you've likely seen this thread before, but reading through existing threads isn't helping, so I thought I'd try asking.

I have an iPod Touch 2G 16gig model, 3.1.2 with blackra1n. Everything's been working great until this evening when I synced my device. The device rebooted, and then went into a constant reboot cycle.

After fiddling with it a bit, I decided, OK, go for a full restore, and clean up the mess afterwards.

The iPod Touch does go into restore mode, by holding the power and escape buttons at the same time for 10 seconds and then releasing the power button. iTunes recognizes the iPod Touch and asks if I want to restore. The iPod goes to the progress bar screen, iTunes says it's verifying the restore with apple, and then says "waiting for iPod", and then nothing happens for a very very long time.

I believe I've also managed to put the iPod Touch into DFU mode, where the screen is black during the restore, and then turns white. Same problem. iTunes says it's waiting for the iPod, and then the progress bar doesn't move.

I've tried running blackra1n again, as some have suggested. It similarly gets stuck during install.

I'm wondering if there's any tricks I haven't tried yet, or if it's time to head to a Mac store... :(

Thanks in advance!
 

dvdhsu

macrumors 6502a
Mar 28, 2008
964
0
Palo Alto, CA
Try draining the power, then clean booting and try your same process again.
Sounds like you tried everything I would've, I can't help you anymore without paying you a visit. ;)

The Apple Store is what it'll probably come down to.

Good luck!
 

TrevorB

macrumors newbie
Original poster
Nov 28, 2009
9
0
Running Blackra1n again seems to have kicked it out of permanent recovery mode, but it's still never making it past the apple logo.

I phoned Apple, they've asked me to send it in for repair. :|

Trevor
 

TrevorB

macrumors newbie
Original poster
Nov 28, 2009
9
0
Just drained the power, got it down to the "Charge Me!" empty red battery screen, tried it again, but didn't see any difference. I'm not sure exactly what the drain power procedure is though.

Thanks for the help so far!
 

TrevorB

macrumors newbie
Original poster
Nov 28, 2009
9
0
IT LIVES! IT LIVES!

I wish I knew what I did... tried downloading a different ispw on my windows machine, clicked it, that restore didn't take, but on what felt like the 50th try for a restore in DFU mode, the restore worked and stuck.

My iPod Lives!!!!!

*pinches himself*
 

TrevorB

macrumors newbie
Original poster
Nov 28, 2009
9
0
Just to document this properly, I think what happened was that I attempted a restore with an older firmware (2.2). I had been getting errors saying the firmware was incorrect... I realize now I was trying to push iPhone ipsw files onto an iPod. When I regrabbed the ispw files as *iPod* files, things went better. 2.2 iPod ispw *didn't* take, but gave a different error. When I then pushed 3.1.2, it *did* take.

Hope this info helps somebody else in my predicament.

All this has scared me off jailbreaking for a while. I think I'm going to leave it as is for now and see if it fails again in the next few days.
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.