iPod Touch 2nd Gen - No Volume Bar!

Discussion in 'iPod' started by DTran11, Aug 8, 2012.

  1. DTran11 macrumors newbie

    Jun 30, 2012
    Hey guys,

    I have a iPod Touch (2nd Gen) running iOS Version 4.2.1.

    I've had this for many years but a problem occurred about 2 days ago.

    Whenever I plug in my headphones, I have the volume bar.

    Without headphones, I don't have the volume bar and no sound comes out of the speaker. I believe it thinks it is still in headphones mode when it's not.

    I reset the iPod Touch, cleaned the charge port and headphone jack and still no dice! I even read that if you have a dock for it, that might've caused the problem. I do have a dock to listen music (iHome). I read online that you could plug it back in, play a song, and unplug the iPod out and it should work again. I tried that many times but still nothing! :/

    Please help guys. I'm kinda desperate :/ really want my iPod to play sounds through the speaker again.

  2. aarond12 macrumors 65816


    May 20, 2002
    Dallas, TX USA
    Do a backup then a full restore (erase/restore) without restoring your backup yet. Add a song or two and test it out. If you're still having the same problem, it's not software, it's hardware. If that fixed it, restore your backup and enjoy your music.

Share This Page