iPod touch iPod Touch 2nd Gen - No Volume Bar!

DTran11

macrumors newbie
Original poster
Jun 30, 2012
9
0
Hey guys,

I have a iPod Touch (2nd Gen) running iOS Version 4.2.1.

I've had this for many years but a problem occurred about 2 days ago.

Whenever I plug in my headphones, I have the volume bar.

Without headphones, I don't have the volume bar and no sound comes out of the speaker. I believe it thinks it is still in headphones mode when it's not.

I reset the iPod Touch, cleaned the charge port and headphone jack and still no dice! I even read that if you have a dock for it, that might've caused the problem. I do have a dock to listen music (iHome). I read online that you could plug it back in, play a song, and unplug the iPod out and it should work again. I tried that many times but still nothing! :/

Please help guys. I'm kinda desperate :/ really want my iPod to play sounds through the speaker again.

Thanks!
 

DTran11

macrumors newbie
Original poster
Jun 30, 2012
9
0
388 views and 0 replies.

Come on guys :( Please. It sucks not having your speaker working.
 

Shotgun OS

macrumors 6502a
Dec 18, 2006
504
0
Ohio
From what you've said, I think its probably a stuck contact for the headphones. My older Macbook had a similar issue where when I pulled out the cord to my speakers, it wouldn't register that it was removed. Best bet is probably to just keep shoving and turning a headphone jack into it, maybe try compressed air, or maybe prod some tweezers in the jack. Not really much help, but its all I've got.