iPod touch 2nd Gen won't launch any apps

Discussion in 'iPod touch' started by imahawki, Dec 25, 2011.

  1. imahawki macrumors 6502a

    Joined:
    Apr 26, 2011
    #1
    So I'd handed down a 2nd gen 8GB touch to my daughter to play games. She wanted a new game on it today so I downloaded the game and then went to sync.

    When I did I noticed on the iPod that about half the icons were just white squares instead of being the actual icon. I figured maybe the sync would fix it. It didn't and when I tried launching the new game it crashed. I tried a couple of the other games and they all crashed too.

    So I did a restore and set it up as NEW iPod, I figured restoring from the backup would be a bad idea. That didn't work, so I rebooted it and it still doesn't work. The icons are all correct now but what I've discovered is all the native apps will launch, but NOTHING ELSE will. It flashes up the splash screen for the app and then immediately closes. This is the case no matter how "light weight" the app is, like solitaire or some other very simple game.

    I'm really frustrated at this point! Any ideas?
     
  2. JTea macrumors newbie

    Joined:
    May 21, 2012
    #2
    I just had the same issue. I opened the AppStore app on the device logged in (installed an update for one app) and now all orher apps are back to normal as well.
     

Share This Page