Ipod Touch 3rd Gen, 4.0 Upgrade. Too late?

Discussion in 'iPod touch' started by cait123, Oct 28, 2012.

  1. cait123 macrumors newbie

    Joined:
    Oct 28, 2012
    #1
    Here it is fall of 2012, and I have finally decided I'd like to upgrade my 3rd gen , 32 gig Ipod touch to 4.0 software. I can't seem to figure out why it's not working... I keep getting the error:

    "this device isn't eligible for the requested build"

    Now, my ipod is not jailbroken. I took a look at my host file, there is no gs.apple redirect going on. I am running Itunes 10 on Leopard 10.5.8, and I only want to upgrade the Ipod touch so I can use the square app to process credit cards.

    Any idea why I keep getting this message or how to update?

    I would just install 5.0 but I would need to upgrade my whole mac op system to keep moving up with itunes. I just want to be able to run 4.0.
     
  2. max53389 macrumors member

    Joined:
    Jul 25, 2012
    #2
    Assuming since you haven't jailbreaked before probably means that you would not have the shsh blobs needed to go to 4.0 and you can only go to the latest version. Which for your iPod is iOS 5 and I don't see why you would need to update your Mac and you could find a friend or family member who has a better computer to update your iPod.
     
  3. Nermal Moderator

    Nermal

    Staff Member

    Joined:
    Dec 7, 2002
    Location:
    New Zealand
  4. cait123 thread starter macrumors newbie

    Joined:
    Oct 28, 2012
    #4
    Solved

    Thanks so much lifesavers. I tried 10.6.3 with IOS 5. Works!
     

Share This Page