iPod Touch 3rd Gen Issue - Stuck on Apple Logo & Restore Fails

Discussion in 'iPod touch' started by dwmcc, Sep 9, 2010.

  1. dwmcc macrumors newbie

    Sep 7, 2010
    Hello All,

    I recently bought an iPod Touch 3rd Generation from Apple. It had software version 3.1.3 on it and I jailbroke it on my MacBook with Spirit. I had decided to upgrade to 4.0, and thought "Oh, I'll restore it so I have a blank 3.1.3, then upgrade to 4.0.". I tried to do this and whenever I click 'Restore', it would download the 3.1.3 software, try to install it to the iPod Touch, and would give me an error. I saw on the Apple website that you may need to update your iTunes version, so I did so. Tried the restore again, and no error. Something happened, though, and I'm not sure what it is. Here are the symptoms:

    When I try to turn the iPod Touch on by itself: It goes to the Apple logo screen like it does during normal start up. It stays there forever, no progress bar, nothing. Just stuck on the Apple screen.

    When I try to turn the iPod Touch on while connected to a computer: It does the same as above, and iTunes does not recognize it.

    When I turn the iPod Touch on, and hold the home button (to put it into restore mode, I think), it goes to the Apple screen, then to the 'Connect to iTunes' screen. I connect it and iTunes detects and iPod Touch in restore mode. When I try to restore it, using 3.1.3 or 4.0, iTunes downloads the package, and extracts it to the iPod. No errors. It then says 'Installing Software', or something of the sort. The progress bar in iTunes moves like it should and it moves like it should on the iPod Touch. When the progress bar is about 3/4 of the way done in iTunes, it stops, and at the same time, the progress bar is almost exactly 1/2 of the way done on the iPod touch. At this point, both progress bars are stuck forever. I've left it on as long as a couple hours and it stays there, doing nothing, stuck. Then when I remove the cord, I get an error in iTunes, which can be expected, and the iPod Touch will be stuck at the Apple screen again!

    Apologies for the long message. Any and all help would be greatly appreciated!


Share This Page