iPod Touch 3rd Gen Starting To Piss Me Off

Discussion in 'iPod touch' started by davmcn, Apr 2, 2011.

  1. davmcn macrumors regular

    Joined:
    Jan 5, 2011
    #1
    Hi,

    I've had two 3rd Gen iPod Touches because one of them got replaced as it thought it was getting charged when it wasn't even plugged in. I got a new one from Apple Store that day and all was well till recently.

    The new one I've had since around November 2010, The home button always seems to act up and never goes out of apps,or it just kind of sits there. Is this new 4.3 that's screwing with me or is it actually the iPod that's being a pain in the @$$ ?
     
  2. Coasterfanryan macrumors regular

    Joined:
    Nov 28, 2010
    Location:
    Pittsburgh Pa
    #2
    try a hard restart. Hold the Home+Sleep/wake button until it turns off, then power it back on. This kept happening to my 2nd gen and this fixed it.
     
  3. davmcn thread starter macrumors regular

    Joined:
    Jan 5, 2011
    #3
    Tried it , still the same old story sadly.
     
  4. J&JPolangin macrumors 68030

    Joined:
    Jul 5, 2008
    Location:
    Thule GL @ the TOW
    #4
    ...you still have 6 months left on the first year of applecare even if you didn't get the "extended" applecare so why not take it into apple for a look?
     

Share This Page