iPod Touch 4G Headphone jack not working.

Discussion in 'iPod touch' started by MDCR661, Apr 5, 2012.

  1. MDCR661 macrumors newbie

    Joined:
    Mar 31, 2012
    #1
    I installed a new volume/ power button flex on the iPod. I had to isolate the battery so I desoldered the + connection and when I soldered it back on the iPod worked fine except the headphone jack doesn't work unless it's full blast and it sounds all distorted and scratchy? So I took it apart again to check the HPJ flex cable and made sure it had a secure connection, but after reassembly it still does the same thing? I'm hoping the headphone jack just needs to be replaced. Anyone have the same problem?
     
  2. thegreati macrumors regular

    Joined:
    Feb 22, 2012
    #2
    Replacing the Audio jack is def. something you could give a try seeing it's not a very hard repair. If that doesn't resolve it there very well could of been some damage done to the logic board during the initial repair, unfortunately :(

    Keep me updated!
     
  3. MDCR661 thread starter macrumors newbie

    Joined:
    Mar 31, 2012
    #3
    Ok I ordered one it's on it's way. I'll let you know what happens.
     
  4. MDCR661 thread starter macrumors newbie

    Joined:
    Mar 31, 2012
    #4
    So I put the new one in but to no avail!! :mad: so I guess I'm just going to sell it as is on eBay.
     
  5. flashyman macrumors member

    Joined:
    Apr 9, 2012
    #5
    My friend had the same problem. he solved it by replacing Headphone Jack
     

Share This Page