iPod touch 4g not fully charghing & not seen by PC / itunes

Discussion in 'iPod touch' started by benniaminn, Jan 13, 2013.

  1. benniaminn macrumors newbie

    Jan 12, 2013
    I had an iPod touch 4g for almost 1.5 years.
    Yesterday it was running low on battery ( <20% ) so i tried to charge it.
    I plugged it in an usb charger (belkin, looks fins) but it didn't show me it was charging. Also, i couldn't see the ipod in "my computer" or itunes.

    So it looked like the cable was broken...

    I tried to restart the iPod but it didn't have enough battery to start again. However, i noticed that the iPod showed that it was charging when it was stopped. If i disconnected it from the usb it would stop charging so the cable was fine.

    So the problem is at the iPod.
    .After a few minutes of charging the ipod started. And then it looks like it stopped charging. The battery icon never gets to green. It stays always on red and it doesn't show me the "lightning/charging" icon anymore. I can see it only when the ipod is shutted down.

    I've read a few posts but none of them helped me solved my issue/none of them had my issue (charging just a little)

    I am worried that water might have affected the ipod since i used it with my hands not so dry a few times. However, it still charges a little. so..why doesn't it charge more & why can't i see it in "my computer"?

    I don't have warranty anymore, and I live in europe (i bought the ipod in usa) so taking it to genius is not an option i want to take.

    I tried different USBs but not different computers yet. Also, asap i will try different chargers, though i think that's now the problem.

    Any ideas would be great.

  2. benniaminn thread starter macrumors newbie

    Jan 12, 2013
    After letting the ipod connected for >4 hours, it looks like it charged a little more. It is now ~30% of the battery. It still doesn't show me it is charging, and my PC / itunes doesn't recognize it.
  3. Solomani macrumors 68040


    Sep 25, 2012
    Alberto, Canado
    Did you try charging it directly to a power (AC) outlet?
  4. benniaminn thread starter macrumors newbie

    Jan 12, 2013
    Not yet, since I don't have one. I'll ask some of my friends to see if one of them has one.
    I tried it on a different PC though, and it's the same issue. no charging and it isn't recognized.
  5. Jhanky20 macrumors newbie

    Jan 12, 2013
    Mine is doing the same thing. Bt no matter how long I have it plugged in it won't charge. I the wall or a computer. And when I y to run redsnow, it won't jailbreak it. And I have no was of downgrading the iOs.. Therefore it's impossible to do anything... Any ideas?
  6. benniaminn thread starter macrumors newbie

    Jan 12, 2013
    so..after a whole day in the usb charger, it charged. Now it is around 90% fully charged, but i will have to unplug it and see how long will it last.

    I will browse through topics tomorrow to see what can i do if my pc doesn't see the ipod / the ipod doesn't show i connected it to the pc ( no duh-dah sound. nothing ).

Share This Page