IPod Touch 4th Gen problem(s)

Discussion in 'iPod touch' started by kyoumi, Jan 4, 2013.

  1. kyoumi macrumors newbie

    Jan 4, 2013
    I got the IPod Touch 4th Gen. 32GB for Christmas , and I'm already having issues .
    I got iTunes working on it the moment I got it (or so I thought .)
    It backed itself up on the comp on Dec. 30th , the last time I plugged it into the comp , but today , it took FOREVER to back up . Like , an hour or so . I thought it was just backing up some of the apps I had recently got . (FB , Twitter , ect .)
    But after the hour , it said it couldn't back anything up on the comp .... I tried again , and the same thing .
    I tried to restore the IPod , but nothing happened , again .
    And now that I've turned it off , it's just at the Apple Logo screen .. and after 10 minutes of staying , the screen does this weird white flashing light , then goes back to the Logo . And won't turn off .
    Is it just the IPod messing up , or did I somehow mess it up by doing all these things on iTunes ?

    (((( If it helps any , I have a shuffle connected to ITunes , and my brother has his own IPod . I believe it's a 4th GEN too ... could we be out of space to back anything up ?))))

Share This Page