iPod touch 5G Not charging! :(

Discussion in 'iPod touch' started by XxpikachuxX, Oct 15, 2012.

  1. XxpikachuxX macrumors 6502

    Jan 24, 2009
    For some reason my ipod touch (red) if that makes a difference won't charge, yesterdar i got this message from my macbook (usb device was drawing too much power) and since then my ipod wont charge not even on my wall outlet my by apple usb charger any help?:confused:
  2. Zmanbaseball2 macrumors 68040


    Aug 24, 2012
    New York, USA
    Try resetting it
    (Hold home button and power or sleep button for 10-15 sec or when apple logo comes up)
  3. XxpikachuxX thread starter macrumors 6502

    Jan 24, 2009
    i just found out my stupid usb cable is not working ;/
  4. MJNBGA macrumors regular

    Mar 26, 2011
    New Zealand
    The Lightning one? Huh? What happened to "durable"?
  5. raccoonboy macrumors 6502a

    Oct 22, 2012
    Maybe "lightning" is referring to the speed of which the thing broke down.
  6. jimmirehman macrumors 6502

    Sep 14, 2012
  7. scarlettsweb13 macrumors member

    Oct 1, 2012
    Durable and reversible! How convenient! I save so much time now that I don't have to figure out which side to stick the connector. I am shocked to hear about the iPod not charging! This was supposed to be a revolutionary device. "The headphone jack is on the bottom", after all. :) Haha, I'm joking.

    OP: In all seriousness, if restoring your iPod does not work; maybe you should just buy another lightning connector?
  8. darkxsky86 macrumors newbie

    Oct 24, 2012
    Don't just buy another connector you gotta go complain to Apple why you got a defective cable because you just bought it and it already broke. Plus that cable ain't cheap I'm guessing its around 30 bucks with the way Apple likes to price their accessories.
  9. XxpikachuxX thread starter macrumors 6502

    Jan 24, 2009
    Trust me its not users error if the cable will not work unless you press really hard on top end iof the conector or other ipods or pcs dont register either
    I took it to apple and they were all surprise they change it for free if not i would of return it and got an nexus 7 ;p
  10. Aspasia macrumors 65816

    Jun 9, 2011
    Halfway between the Equator and North Pole
    If you had read the warranty info, you would have immediately known Apple would replace it at no charge. They have pretty darn good customer service.
  11. sagna macrumors newbie

    Dec 8, 2012
    Temple run

    guys can u help me about the temple run the game, on ipod 5 how can i download that game ? and i founded it on itunes so how do i download it from itunes??:apple::apple::apple::apple::apple::apple::apple::apple:
  12. cc746 macrumors newbie

    Jan 7, 2013
    Waste of money

    I as well have the new 5G iPod touch, when I first got it I plugged it into the computer, picked out my playlist synced it & then charged it and everything was fine. My second time going to charge it I plugged it into my old adapter and after about an hour I started smelling burnt rubber, upon attempting to unplug the adapter from the wall it was extremely hot to the touch. I then tried plugging it into my iPad adapter & although it didn't try to melt or set my wall on fire it will not charge. When I plug it into my Macbook I get the same message that it is drawing too much power & my USB is disabled to prevent damage.

    I cannot believe for the price of this thing it did not come with an appropriate adapter and it obviously has issues charging normally.:mad:
  13. millsash macrumors newbie

    Jan 10, 2013
    Same as me.

    This is exactly the same as me. I have also got the iPod 5g in red and I have just plugged it into charge and it won't. Unfortunately I plugged it in once it had run out of complete charge so I cannot access anything. I have also tried with other adapters, switched off at the mains, switched plug sockets, tried with my computer and it will still not charge - at least I'm not the only one this has happened to. Has yours worked again since and do you have any advice for me?

  14. Killer AG17 macrumors newbie

    Jan 18, 2013
    it not working for either

    its not working for me either :mad::mad::mad::mad::eek::eek::eek::eek::confused::confused::confused::confused::apple::apple::apple::apple::(:(:(:(
  15. Solomani macrumors 68040


    Sep 25, 2012
    Alberto, Canado
    Did you buy one of those $1.50 Chinese generic copycat OEM iPod cables? People buy those from eBay or Amazon all the time, and about 60% of the time they do not work.
  16. AbacabMR macrumors newbie

    Oct 18, 2012
    Had the same problem a few days ago... scheduled an appointment at the genius bar and the gave me a new cable... hope my old cable will serve as one of the many (?) examples which may lead to an improved design (if it is indeed in need of improvement).
  17. Thetonyk123 macrumors 68000


    Aug 14, 2011
    Really simple solution, as stated above, go to the genius bar and get it replaced... end of story. And to the person asking how to get temple run, make an iTunes account then tap "free" then "install"
  18. Niall's Sister macrumors newbie

    Apr 7, 2014
    Perhaps this is the first phone you have ever had. Well first what you do is search App Store or just find the App Store. Then you hit search below and search what you want to download ps you half to have an apple id to download anything at all. Ok so then you will see install you hit that and then it will download fast or slow.Hope this helped good luck!

Share This Page