Ipod Touch 5G Stuck in Recovery Mode

Discussion in 'iPod touch' started by pudelko, Nov 26, 2014.

  1. pudelko macrumors newbie

    Joined:
    Nov 26, 2014
    #1
    Hello MacRumors!

    I have an Ipod Touch 5G that is stuck in what I believe is called recovery mode. The device isnt mine, Im just trying to help a family member recover it. I believe this started when she tried to update to a new iOS through itunes. Im also not sure what version it is running at the moment.

    When I connect it to my PC (running Windows 7) the itunes logo and cable appear on the Ipod's screen. When Itunes boots up I get the message "The software on "Ipod touch" needs to be restored to factory settings or updated."

    I am scared to restore or update because I do not want to loose the files that are currently on the ipod (most importantly pictures from a trip to Europe)

    I have tried the following to exit recovery mode with no luck:
    Recboot, Redsnow 0.9.15b3 , Wondershare Dr.Fone for iOS. All three of these did the same thing, they would reboot to an apple logo and then after a while back to the itunes logo.

    I have also tried to get to the files through Ifunbox but it doesnt detect the device.

    Is there anyway I can recover my files from this device? If I perform an update through Itunes will it erase my data currently on it? Also on the same topic, If I update it not on her computer but mine will that erase her data? Should I perform the update on her computer to be safe?

    Any help would be much appreciated. If there is any other info I can share to help let me know.

    Thanks!
     
  2. LMC91 macrumors member

    Joined:
    Jun 17, 2014
    #2
    Hey, I'm not sure if my method can help, since I've only done it on an iPod Touch 4G on IOS6, but it's worth a try. This has allowed me to SSH into my iPod Touch and pull out any files I needed, even app/game saves, when I was in a Recovery Loop and couldn't use my iPod. When you see that you can access all your files in the mnt2 folder at the end of these steps, try using TinyUmbrella again to see if it kicks it out of recovery.

    Download Putty:
    http://www.chiark.greenend.org.uk/~sgtatham/putty/download.html

    Download WinSCP:
    http://winscp.net/eng/download.php

    Download SSH_RD_Rev03B.jar:
    http://www.sinfuliphone.com/showthread.php?p=781514
    In that link it mentions about needing to install 'JRE-7-Windows-i586-iftw.exe' for it to work, but you can try without it to see if it works.

    Follow the instructions here to get access into your iPod:
    https://github.com/msftguy/ssh-rd/wiki/Windows-How-To

    If /mnt2 doesn’t show, restart the instructions for Putty, and after typing in the root and password, (before typing ‘mount.sh’), enter in:

    fsck_hfs -r /dev/disk0s1s2

    It will go through a repair, wait till it’s done, and mnt2 should work. Hope this works out for you.
     

Share This Page