iPod touch 64g 3rd gen, stuck...

Discussion in 'iPad Tips, Help and Troubleshooting' started by DigitHeads, Aug 1, 2011.

  1. DigitHeads macrumors newbie

    Joined:
    Aug 1, 2011
    #1
    i have a 64Gb iPod touch 3rd gen. my son tried to jailbreak it unsuccessfully and now it is stuck. all i get on the iPod display is the apple and the spinning circle. i have gone into DFU mode and tried to restore, i am unable to load any downloaded IPSW, they all give the same error - device not eligible for build - if i restore it to 4.3.5, it does me no good, the device seems ok in iTunes, but my physical display does not change. how can i recover this device so that it will boot properly.
     
  2. Ashwood11 macrumors 65816

    Joined:
    Nov 10, 2010
    Location:
    US
    #2

    Read first! Please use the appropriate forum or subforum

    To help other users find the iPad threads they are looking for, please choose the most appropriate forum for your new thread.
    Use iPad Tips, Help and Troubleshooting for troubleshooting and problem-solving. This forum is new and we hope you'll take advantage of it.
    Use iPad Accessories for cases, gadgets you connect, etc.
    Use iPad Hacks for jailbreaking and customization.
    Use iPad Launch Meetups for iPad events.
    Use iPad Apps for iPad applications.
    Use the main iPad forum for other iPad topics: features, opinions, ideas, speculation, iOS discussion, and so on.
     

Share This Page