ipod touch and D-link Wireless router

Discussion in 'iPod touch' started by ruthiep, Dec 9, 2008.

  1. ruthiep macrumors newbie

    Joined:
    Dec 9, 2008
    #1
    Just got an itouch and was trying to get it to connect to my wireless. It does not hook up.. my brother "a computer geek" says I need a new router. I have a D-link DIR-625, P/N F330273014139. He says that this particular model does not talk to the itouch. Does anyone know if it will work? This has been a great router so far and I hate to replace it.

    If not what is a good router for several PCs, the itouch, and a Wii?

    Thanks for your help!
     
  2. Avizzv92 macrumors regular

    Joined:
    Mar 23, 2008
    #2
    Does the iPod Touch even detect the wifi? Have you had problems connecting anything else that's not a computer too it? I never owned a D-link perhaps just some simple port forwarding is all that is required. With my Netgear I need too do that for a lot of things like video chats, online games, gaming systems, ect...

    I doubt you should have to get a new router that model type seems too be fairly new since it is wireless N...

    Also do you have the wifi protected with a WEP key or WPA Protected?
     
  3. ThunderBull4 macrumors 6502

    Joined:
    Jul 28, 2008
    #3
    If you do end up having to switch routers, I have a linksys router and it works fine with it.
     
  4. ruthiep thread starter macrumors newbie

    Joined:
    Dec 9, 2008
    #4
    Detecting network

    The itouch does detect the network but when I type in the pass word it says unable to join network? I would have to look to see if it is WEP or WPA. Is there one that work better with itouch?
     
  5. Avizzv92 macrumors regular

    Joined:
    Mar 23, 2008
    #5
    iPod touch has issues with WPA I heard, now for testing purposes remove all security settings then try too connect and see if it does.
     
  6. three macrumors 6502a

    three

    Joined:
    Jan 22, 2008
    Location:
    Washington State
    #6
    Is your router N, or A / B / G? The iPod touch doesn't support N class.
     
  7. g2tegg macrumors member

    Joined:
    Sep 5, 2008
    #7
    Newer D-link routers are N/G/B/A. No routers on the market, from my understanding are ONLY N. They are all backwards compatible. Unless someone got into the router and changed the settings. Anyways, the reason why you are having problems is the type of encryption. Whoever configured your router should be able to change it. Personally I use WEP 128bit. Never had a problem.
     
  8. Avizzv92 macrumors regular

    Joined:
    Mar 23, 2008
    #8
    I searched the router type and it wireless N, but it should be backwards compatible with G.
     
  9. Impulse29 macrumors member

    Joined:
    Apr 12, 2004
    #9
    wifi is a standard so the iPod touch should be able to connect to your router no matter what brand it is. Also the standards are generally backwards compatible with previous ones so an n network would allow a b device on it. I say generally because if one b network goes onto an n network, the entire network is reduced to the speed of the b device so some people (myself included) restrict the n network to only n devices.

    Also, I've used my iPod touch on several networks that use WEP and WPA security, with no problems on either.

    I suggest that you see if you can connect to your wireless network without any security, and if that works see if you can add WPA2 personal security to your network. Lemme know if you get it working.
     
  10. Mister9 macrumors regular

    Joined:
    Feb 11, 2008
  11. Topper59 macrumors member

    Joined:
    Dec 25, 2008
    #11
    sorry to kinda "resurect" a semi-old topic,

    I also have a D-Link DIR-615 and I am having this exact problem. I'm running WPA/WPA2 right now. I'm going to change it to WEP to see if I have any luck
     
  12. Topper59 macrumors member

    Joined:
    Dec 25, 2008
    #12
    ok, if anyones listening

    I changed my security to WEP 64 bit and it works! So for now its okay, but I want WPA2 becuase its a lot more secure.

    So for D-Link routers, just change it to WEP!
     
  13. SnowLeopard2008 macrumors 604

    SnowLeopard2008

    Joined:
    Jul 4, 2008
    Location:
    Silicon Valley
    #13
    Yup yup. The new iPod has problems with detecting WPA2 for some reason.
     
  14. bobgall macrumors newbie

    Joined:
    Dec 22, 2009
    #14
    I have a D-Link 655 also and had initial problems connecting two iTouches. I am using "Both WPA or WPA2" security mode. I couldn't connect until I disabled WISH under the Advanced tab. I have no idea why this worked, but I had tried connecting many times, and this was the setting I changed that made the difference.
    Bob Gall
     

Share This Page