Ipod Touch Applications

Discussion in 'iPod touch' started by yohoo, Sep 12, 2008.

  1. yohoo macrumors newbie

    Joined:
    Sep 12, 2008
    #1
    hello people,

    is it necessary to proceed with a software update before the ipod touch can be installed with applications?. Any kind souls free to reply?
     
  2. Ivan P macrumors 68030

    Ivan P

    Joined:
    Jan 17, 2008
    Location:
    Home
    #2
    You need to have at least firmware 2.0 installed. To check the firmware, connect your iPod to iTunes and it will tell you on the Summary screen. Also, you can go into Settings on your iPod, select General and then About, and it will say the same thing.
    If your iPod already has the App Store icon on the screen, then you can download and install Apps already.
     
  3. yohoo thread starter macrumors newbie

    Joined:
    Sep 12, 2008
    #3
    Thanks Ivan.=)
     
  4. rupie94 macrumors member

    Joined:
    Sep 5, 2008
    Location:
    Leiden
    #4
    Yes you need 2.0 but it's better if you have 2.1(.1) for faster installation and better working apps.
     

Share This Page