iPod touch as a developer device

Discussion in 'iOS Programming' started by beneventi, Aug 14, 2008.

  1. beneventi macrumors member

    Joined:
    Jun 6, 2006
    Location:
    Italy
    #1
    Dear Forum users, I've enrolled as a Standard iPhone Developer. I would like to use my iPod touch as a testing device and have some questions for you:


    1. My iPod touch has 1.5 firmware version installed. I need 2.0 to test apps. The Developer Portal tells me to download the iPhone OS 2.0 for my device. Where do I have to go to download it? I have not found the link.


    • Do I need to pay to update my iPod touch firmware to 2.0?


    • As a Standard Developer can I install as many application as I like on my devices provided that I've created them or I need to go to the iTunes App Store as any other one?

    Best regards

    Alessandro
     
  2. tacoman667 macrumors regular

    Joined:
    Mar 27, 2008
    #2
    You MUST have 2.0 on your device in order to load apps.

    You will need to pay the $99 fee in order to load your application onto any device. If you just want to you the simulator, it is free and you only need to install the SDK from the developer site.

    You need a wildcard provisioning file on your machine, you will understand later, and you can create and install as many applications as you like.
     
  3. beneventi thread starter macrumors member

    Joined:
    Jun 6, 2006
    Location:
    Italy
    #3
    Hello, I've already paid the 99$ fee, I have the developer certificate. What I need to know is if I can download the OS image for my iPod touch from the developer site or I have to pay for it as a standard user.

    Regards
     
  4. Ron C macrumors member

    Joined:
    Jul 18, 2008
    Location:
    Chicago-area
    #4
    I went the same route and I just ended up purchasing the 2.0 software.

    Ron C
     
  5. tacoman667 macrumors regular

    Joined:
    Mar 27, 2008
    #5
    Good question. I am sorry I didn't understand it though. If you already paid the fee then when you log into the developer.apple.com/iphone website it will have the SDK download and any development downloads available to you. Mine shows the iphone EDGE, 3G, and touch OS's but I was one of the original 4000 allowed into the beta so I get the betas for 2.0 and now 2.1. Mileage will vary...
     
  6. Greencardman macrumors 6502

    Joined:
    Apr 24, 2003
    Location:
    Milwaukee, WI
    #6
    You might have to pay for your Touch update like everyone else even though you're a developer. You should email Apple and ask, but if you can't find a link to a free update or you can't install a beta, you're probably going to have to buy the Touch update.
     
  7. beneventi thread starter macrumors member

    Joined:
    Jun 6, 2006
    Location:
    Italy
    #7
    When I log into developer.apple.com/iphone I get the iPhone SDK download link, the Program Portal link but no way to download the touch iPhone OS. Can you please tell me exactly where your link is and which is the provided description?

    It seems to me insensate to be able to test on a touch only if I pay the upgrade. It would be like if I was a Select ADC member without new OS seeds.

    Thanks.

    Alessandro
     
  8. beneventi thread starter macrumors member

    Joined:
    Jun 6, 2006
    Location:
    Italy
    #8
    Thanks. Which is the Apple email you suggest me to use?

    Alessandro
     

Share This Page