iPod Touch broken headphone jack

Discussion in 'iPod touch' started by dvdhsu, Feb 8, 2009.

  1. dvdhsu macrumors 6502a

    dvdhsu

    Joined:
    Mar 28, 2008
    Location:
    Palo Alto, CA
    #1
    Yesterday, I finally decided to get those new shiny Apple In-ear Earphones.
    Upon getting them, I instantly tried them out, and decided the sound quality was decent.
    However, after about a few hours of listening, I unplugged, and went to bed.
    Somehow, today, when I tried using them again, the plug doesn't go all the way in. I can hear music, but it constantly falls out, making it impossible for me to hold my iPod Touch in my hands if I want to listen to it.
    I took a look inside the headphone jack, and everything seems to be all right in there, the sticker is still white, meaning no water damage, and I don't see anything (sorry- no ball- like another poster had:D).
    I have tried this with other headphones and speakers, and on may speakers, it woundn't even output sound.
    Unfortunatley, I am out of warranty, so I am assuming I'll just have to replace the whole Logic Board. This seems unfair to me, because it seems to me that the earphones somehow broke my jack.
    What do all you guys think?
    Is it possible that Apple will decide to replace my Logic Board?
    Thanks,
    David
     
  2. Texas04 macrumors 6502a

    Texas04

    Joined:
    Jul 2, 2005
    Location:
    Texas
    #2
    I would take it down if you could and explain the situation. Be as courteous as possible and they might just do it. Do you have apple care and is the computer under warranty?
     
  3. dvdhsu thread starter macrumors 6502a

    dvdhsu

    Joined:
    Mar 28, 2008
    Location:
    Palo Alto, CA
    #3
    Ah.
    Sorry, I wasn't very clear.
    It is the iPod Touch that is broken. Because the headphone jack is now in the logic board, I said logic board. It seems to me that there is no way of DIYing without replacing the whole logic board.
    Thanks for the help though.
     
  4. Flyingbadger macrumors newbie

    Joined:
    Nov 17, 2010
    #4
    One possible reason for this problem

    Yeah, I know it's a pretty old thread, but it's one of the first that comes up after Googling for "ipod touch headphone socket broken". Appreciate it might not be any use to the original poster, but for anyone else who reads the thread after searching...

    I just randomly fixed the same problem with my 2nd gen Touch. It turned out, there was a load of pocket fluff in there (I believe US folk call it lint). Repeated attempts to put the headphones in had impacted it.

    I simply poked about with a paperclip, saw it all fall out, and now the headphones seat properly again.

    A bit basic, I realise, but there you go :D
     

Share This Page