iPod touch buttons malfunctioning

Discussion in 'iPod touch' started by kenai, Dec 6, 2008.

  1. kenai macrumors newbie

    Joined:
    Dec 6, 2008
    #1
    Hello all.

    :apple:The device is an iPod touch 2g, 8gb, software version 2.2, in a Griffin 'iClear' case.

    :(-----Short version-----
    A whole bunch of weird stuff happened, the sum of it all being that the volume of my iPod will not rise, as if the volume-up button on the side of my iPod is being held down with only short rests in between. I have reset it several times (six total) and deleted anything unused, but no effect seems to be had. I don't want to restore the iPod, as I am 3000+ miles away from the computer where this iPod is synced. Please help.
    -----End short version-----

    :mad:-----Long version-----
    Today, for some odd reason, the touch's buttons started to freak out on me. I was watching a short video, and the volume started to go down on its own, at random times. For a while this happened only if I turned the iPod to the left (volume buttons down), so I turned it to the right. This started not to work. Then, I found that I could fix it for a time by locking the iPod, then resuming the video. This started to not work.

    I then noticed that the 'down' volume button worked as if you were tapping on the screen while playing video, and not at all anyplace else.

    Then, the lock button decided that it was the 'down' volume button, at random times.

    Following suite, the home button decided it's not going to work either, unpredictably.

    As you can imagine, this is all very irritating.

    I have tried everything anybody has said works for them (several times each)- resetting the iPod (4 times), quitting the music program completely by holding the home button (2 times), praying really hard (this whole time), and using 'the Force' (four times, while the iPod was resetting).

    After all this, I tried deleting all the extra videos, unused apps, and pictures I had on the iPod. I reset it a fifth time. It didn't work (obviously).

    Now, the volume-down button seems perpetually pressed, and there has been no reprieve for more then a minute since I started writing this, even though I have reset it a sixth time.
    (The other buttons now seem to function as normal; just the volume-down button seems relentlessly pressed.)

    All this has taken place over the course of about four hours. I don't really want to take the 'give it time to heal' approach. I also don't really want to restore the thing, as I am 3000+ miles away from home (and from the laptop to which this is synced), and will be until February.
    -----End long version-----

    Note- The apps I was using immediately before this, in this order: Videos, Nanosaur 2, Lightsaber Unleashed, Zippo Lighter, Photos, Email (from Photos) then Videos again, when it started. I have not been connected to WiFi at all today until after it started.

    Also Note- Any comedy attempted here was meant only to give a laugh, not to be inflammatory or to imply the request for help is not serious. Thank you for your time.
     
  2. ThunderBull4 macrumors 6502

    Joined:
    Jul 28, 2008
    #2
    How long ago did you buy it? And also, if you restore now on another computer, you can always restore back to what to had on the one before (assuming you backed everything up)
     
  3. archurban macrumors 6502a

    archurban

    Joined:
    Aug 4, 2004
    Location:
    San Francisco, CA
    #3
    it sounds like hardware problem. it is nothing to do restore what not. go to Apple store, fix it. it will be taken few days for getting back.
     

Share This Page