iPod touch "Cannot be synced. The Required disk cannot be found"

Discussion in 'iPod touch' started by john101, Oct 2, 2007.

  1. john101 macrumors newbie

    Sep 29, 2007
    Liverpool [UK]
    I finally received my Ipod touch today!
    After the registration process on iTunes, I tried to sync my music to the iPod Touch but I kept receiving the error message "Ipod Touch cannot be synced. The Required disk cannot be found". (I have XP by the way)

    I have tried the Touch on my sister's computer (Vista) and it seems to be syncing perfectly. I don't know where I am going wrong; I have updated iTunes and the iPod software. I have also tried re-installing itunes, Restarting/Re-setting/Restoring the Touch itself.

    Can anyone help?

  2. Vigilante macrumors 6502a


    Sep 11, 2007
    Is your main drive C:? I have heard of problems before similar to yours when people have mutliple drives, but their main drive is D:. If your files are on the iTunes library and work fine, though, I have no idea.
  3. john101 thread starter macrumors newbie

    Sep 29, 2007
    Liverpool [UK]
    Thanks for your reply!
    I have multiple drives, the main drive is C: and the second drive is D: (apparently this is only used as a recovery partition)
  4. john101 thread starter macrumors newbie

    Sep 29, 2007
    Liverpool [UK]
  5. john101 thread starter macrumors newbie

    Sep 29, 2007
    Liverpool [UK]
    Nope, tried everything on that page, and it still doesn't work! :(
    I really don't know what the problem could be.
    Thanks anyway,
  6. john101 thread starter macrumors newbie

    Sep 29, 2007
    Liverpool [UK]
  7. Arisian macrumors 68000


    Sep 14, 2007
  8. DeXtA macrumors member

    Sep 19, 2007
    Ever thought of just getting your itunes library and changing the location to a flash drive or external drive? Might be worth a go?
  9. john101 thread starter macrumors newbie

    Sep 29, 2007
    Liverpool [UK]
    I'm going to try and move my itunes library to my sisters computer - and just use that instead, until i find out exactly what the problem is.
    Thanks for the replies :)
  10. svngpvtry macrumors newbie

    Aug 20, 2008
    This might be a little late to help you but it might help others.

    If you are getting this error as I have the only solution i have found so far is

    After you hit the sync button and begin syncing your ipod simply unplug a mouse or other device plugged into another USB port. I do not know why this works but it does.

    I also have found that a fix for this problem on PCs is to go to

    control panel>System>Hardware Tab> Device Manager Button>Highlight your computer name>then click Scan for hardware changes button on the toolbar at the top.

    Between the two this seemed to fix most everyones problem even if it is a pain.
  11. MikeInSteamboat macrumors newbie

    Aug 31, 2008
    Steamboat Springs, CO, USA
    It worked for me!

    svngpvtry's solution worked for me.

    I had been successfully syncing my shuffle for a year with this PC when the problem started.

    I spent two hours with iPod support to resolve the issue this past week. The tech had me restore my shuffle, re-register DLLs and "Scan for New Hardware (from the device manager) -- all to no avail.

    Apple sent me a replacement shuffle, but I had the same problem with the new shuffle.

    I un-installed iTunes and re-installed it -- to no avail.

    I desperation I found svngpvtry's post, tried his solution and it worked. I had to perform both steps -- scan for new hardware, and the pull the plug on another USB device after initiating the sync process. Unfortunately I also found that I must go through the same ritual every time I want to sync - quite an annoyance.
  12. P8ntmagnit macrumors newbie

    Sep 10, 2008

    I have to say, I created an account just now for the sole purpose of backing up the "pull a USB" method. I'm not sure if the hardware scan did anything but it didnt work when I tried it alone. Also, I'm wondering if the removed USB has to be connected to a device or if it can be just like an empty hub that can be removed. Either way, thank you, what's an ipod without music?

    fyi; this worked on the original Iphone, V2.0.2
  13. edcoche macrumors regular


    Nov 2, 2007
    So, after installing the new iTunes 8.0 my iPod is suddenly having issues with iTunes. When I plug in my nano iTunes loads up like normal, and it says "The disk can not be read from, or written to" yet I still can see the songs I have on there, just not add to it. Under the previous version of iTunes I could plug in my nano and add and delete music without any issue whatsoever. Could have apple implemented a way for a water damaged nano to be incompatible with their new release, forcing the user to buy a new one?? My nano has been working just fine up until the update after it fully dried out.

    I don't want to restore it, because it could not allow me to put anything on it after clearing out the memory.

    Is it possible for me to reinstall a previous version of iTunes?
    this is taken from a thread I started after I dropped my ipod in the lake.


    The device works fine now and has been problem free until iTunes 8 came out! Now I cant add or take off music all of the sudden... :(
  14. m.breevoort macrumors newbie

    Oct 18, 2008
    I have an ipod nano 4th generation and updated to firmware 1.0.2. I couldn't change any setting (it tried to apply changes but never worked) when I wanted to upload videos I got the message "the iPod cannot be synched. The required disk cannot be found". My first iPod and I really hate iTunes.
    When i changed the setting for enable disk and disabled auto synch. Then I had to scan for new hardware and that worked, great!
    Now it is usable but iTunes still sucks
  15. crisprodigy macrumors newbie

    Oct 30, 2008
  16. erich13 macrumors newbie

    Nov 28, 2008
    This worked for me, on my iMac, withmy new iPod Touch, with iTunes previously syncing with a 3rd Generation iPod. I'm thinking that this means that the common denominator is unplugging something else from the USB bus, in this case, a USB I card reader that also gives me problems unrelated to iTunes/iPod use.
  17. pravzz007 macrumors newbie

    Feb 22, 2009
    I received my Ipod shuffle today!
    After the registration process on iTunes, I tried to sync my music to the iPod Touch but I kept receiving the error message "Ipod cannot be synced. The Required disk cannot be found". (I have XP by the way)

    Can anyone help?

    What did u do John for the same problem as mine?

  18. harleyg98 macrumors newbie

    Aug 7, 2009
    Problems with synching iTouch

    I've been using Macs for years and the iTouch for two years.

    I've never had a problem with synching until this week.

    This might be a clue to the problems that PC/Windows users are having.

    I'd bought a new external disk drive and had to resort to a USB hub to gain the ports I needed.

    This caused me a whole string of problems - only resolved when I connected the iTouch directly into a Mac USB, did a complete 'Restore to Factory Settings' then a resynch.

    It's now working fine.

    The problem has to lie with the USB. It's not a powered one - it takes it's power from the computer. Maybe a powered USB hub would work, but it you have a similar problem try this out.

    Good luck
  19. brian5 macrumors member


    Jul 15, 2008
    CT, USA
    I have this problem on my PC ONLY with the nano 4G. No problem with iPod 3G, iPod Classic, or iPhone 3G.

    Last time, I did a complete restore of the nano 4G and was able to get it to sync ONCE. A week later, I'm trying to sync it again and I can't get it to sync. Looks like I'll have to try a darn restore again!! :mad:
  20. Lexy007 macrumors newbie

    Sep 20, 2009
    I have the same problem that John originally had, except that i'm using a laptop that doesn't have any usb hubs to unplug. I've tried scanning for hardware but that doesn't help. :s
  21. ibsaxena macrumors newbie

    Nov 18, 2009
    The cable is faulty

    I faced the same problem mentioned in this thread and after trying everything possible, i used a sync cable from and old iPod Mini that I had. Faced no problem after that. Its the bundled cable that faulty and doesnt carry enough current and causes the error while syncing. There is no other issue.
  22. Moose72 macrumors newbie

    Nov 27, 2009
    SVPVTRTY-- You're the man, well, maybe the woman.

    First time this problem popped up on my nano and I hit sync, disconnected a usb printer, and the damn thing works. Why? Dont know and dont care. Thanks a bunch! Just realized I butchered your name- sorry about that
  23. kingpaddy123 macrumors newbie

    Nov 29, 2009
    syncing problems


    the other week i brought my friends touch 2.0 off him, took it home and took all the music off it and tried to put all my music back onto it. it was working fine until on certain songs everything would freeze and finally it would say device time out or error occured (-6999) or something like that. i dont have a mac computer and most of the songs were downloaded off frostwire and other downloading projams. CAN ANYONE PLEASE HELP AND TELL ME WHAT GOING ON AND TELL ME HOW TO FIX THIS???:confused: oh and it only happens with songs.
  24. Steadinan macrumors newbie


    Dec 27, 2009
    "cannot be synced" "required disk cannot be found" POSSIBLE SOLUTION

    I got that same error message on my 1st generation iPod on my Mac (with Snow Leopard). I was able to get around it by removing a 500 MB playlist FIRST, then adding another one. I thought a computer would just be able to replace the old with the new, but apparently not! I didn't have to reinstall anything or unplug or anything that everyone is suggesting. I just had to make room on my iPod before adding more songs. (It doesn't do a "replace".)

Share This Page