Ipod touch - charges with Fiewire but not USB

Discussion in 'iPod touch' started by randomname, Apr 8, 2010.

  1. randomname macrumors newbie

    Joined:
    May 17, 2007
    #1
    My ancient Firewire cable broke today so I grabbed the USB cable that came with it to charge it. Seems that it won't charge and my computer (imac) doesn't recognize it. I've since tried a friend's cable and plug that works fine on her nano, but still no joy.

    Am I missing something really obvious???
     
  2. Skyhigh223 macrumors regular

    Joined:
    Jul 21, 2009
    #2
    Make sure that you're plugging it directly into a hub on the iMac itself.

    Don't use the ports on the keyboard, don't charge the iPod while the iMac is asleep.

    If that doesn't work then it's possible that the connectors on your iPod are broken.

    And anyway, I didn't think you were actually able to charge iPods via FireWire anymore...
     
  3. cjacks68 macrumors regular

    cjacks68

    Joined:
    May 27, 2009
    #3
    I think you can still charge via FW, but not sync anymore.
     
  4. randomname thread starter macrumors newbie

    Joined:
    May 17, 2007
    #4
    Turns out it's broken! Wasn't the firewire lead that died, it was ipod.
     

Share This Page