iPod Touch connects with public wifi hotspots but NOT our network

Discussion in 'iPod touch' started by chnine, Apr 15, 2010.

  1. chnine macrumors newbie

    Joined:
    Apr 6, 2009
    Location:
    Northern California
    #1
    [FONT=Calibri, Verdana, Helvetica, Arial]Hi, [/FONT]

    [FONT=Calibri, Verdana, Helvetica, Arial]Recently, we got the latest iPod Touch. It is unable to connect to our wifi network that all our laptops and other devices use. It sees our network, logs in with password, LOOKS like it’s connected but it doesn’t do anything.

    It has connected just fine with other wifi networks — public ones, hotspots, wifi at a recent conference we were at with no issues. These were all non-passworded networks.

    Our router is a Netopia Model R3100-U ISDN Router which connects us to our ISP (whopping dual-band 128kbs... we are in a rural area so it’s the most reliable). Ethernet corded to that router is an Apple Time Capsule (in bridge mode), which of course makes the wifi setup work. Then we extend the network with two Airport Express devices. This has all worked fine for a long while ... but NOT with this new iPod Touch (or with a friend's iPhone last month, come to think of it.).

    When I go into wifi settings on the iPod Touch, it is seeing/registering all the correct router settings (an available 168.XXX.XX.XX IP address, router address, DNS, etc.) but it DOES NOT connect or serve up a web page (or anything else).

    Also when I telnet into the ISDN router and look at the IP addresses, it actually registers an IP address 'reserved' for 'iPhone' ... so it IS seeing the device. Weirdly, the IP address that the DHCP on the iPod Touch grabs is NOT that same one.

    I’ve spend *hours* on the phone with Apple troubleshooting this and they cannot see any problem in any of our setup ... nor with the device itself. I have reset the thing (and the network) a bunch of times and it hasn’t yet worked. I have set our network up with NO password and the iPod Touch STILL can’t join it.

    I contacted the Netopia router people -- who have discontinued the product and can provide no support -- other than this page on their site:
    http://www.netopia.com/support/hardware/r_3100u.html


    So here’s my question: from this info, can ANYONE (a network person?) tell whether there is any reason why we should be having trouble with our R3100-U ISDN router allowing the iPod Touch Internet connection? Moreover, I would be so grateful if someone can assist us with fixing this.

    Thanks,
    Christina[/FONT]
     
  2. jzuena macrumors 6502a

    jzuena

    Joined:
    Feb 21, 2007
    Location:
    Lexington, MA, USA
    #2
    Network person here :)

    It is possible that there is an incompatibility between the DHCP server in the ISDN router and the DHCP client in the iPhone/touch. I don't know if you can have a bridge mode Time Capsule act as a DHCP server... probably not. The next best thing might be to at least test setting up the Time capsule as a router so that you can have it act as a DHCP server. Your ISDN router seems to support having a network with multiple subnets (see NIR_012: Subnetting; Netopia Router-to-Netopia Router except "Netopia B" would be your Time Capsule). Then your setup would be:

    (Outside IP address) [ISDN Router] (Current inside IP network) [TC] (New inside IP network) [computers including iPhone/touch]
     
  3. Adam0306 macrumors regular

    Adam0306

    #3
    I haven't had much experience with the Netopia, but my iPod Touch every now and then will not connect to our non-broadcasting network. All I do is go into wireless and "forget the network". After this it will connect just fine.:confused:
     

Share This Page