Ipod touch download problem

Discussion in 'iPod touch' started by Captainidontno, Oct 2, 2010.

  1. Captainidontno macrumors newbie

    Aug 25, 2010
    ive got the ipod touch 4 and tried to download Epic's Citadel over wifi in my house.
    when it exited the app store and showed the home screen, the icon popped up on the home screen and said waiting.
    its been a while and it still shows this:

    Attached Files:

  2. Intell macrumors P6


    Jan 24, 2010
    It may be wanting your password. Try restarting the iPod and trying the download again. If that doesn't fix it you'll have to download the app in iTunes on your computer then sync it over.
  3. Mr Slippy IV macrumors 6502

    Mr Slippy IV

    Feb 24, 2010
    Vail, AZ
    Also, try double-tapping the app icon. Worked for me once. And only once.
  4. Captainidontno thread starter macrumors newbie

    Aug 25, 2010
    i got it fixed. i plugged it to my computer and then downloaded the app. then i deleted the app first from my ipod and then from my computer.

Share This Page