iPod Touch downloaded apps will not launch. Any Advice? Any Solutions?

Discussion in 'iPod touch' started by xSchantelleStar, Dec 25, 2009.

  1. xSchantelleStar macrumors newbie

    Joined:
    Dec 25, 2009
    #1
    I recently got a 8GB iPod Touch also recently updated to version 3.1. But before I updated my iPod, the apps i downloaded were being shady. In other words, they would not launch. About an hour before this happened, it working perfectly fine. &After I plugged it into my laptop, it was still working fine, until i downloaded another app. Did I do something wrong? But I searched this problem in google, &a bunch of people had this problem. So obviously, this problem is not rare. Any suggestions? Advice?

    &Before you suggest that i reset the iPod settings, I have already tried that. Same with turning off my iPod, &back on. I have also tried uninstalling & reinstalling. Anything else? I'm thinking about just going to the Apple store, but I can tell that this problem isn't that serious. Thanks. :confused: :apple: :D
     
  2. tadad1 macrumors 6502a

    tadad1

    Joined:
    Oct 20, 2008
    #2
    Can sometimes be an authorization issue, couple of things you could try, make sure iTunes is logged into the account that the apps were purchased from and then sync your device, or download a free app directly to your device from the appstore, doing so will require you to enter your account details which should fix the problem.
     

Share This Page