ipod touch frozen on apple screen

Discussion in 'iPod touch' started by aaa2260, Aug 24, 2010.

  1. aaa2260 macrumors newbie

    Aug 24, 2010
    today, i deleted an expired free trail of iacces on my ipod using i-fun box by right clicking, then delete (kind of like winscp)
    when i try to restart it, its frozen on the apple screen.
    i tried the method where i plug it into the computer, and hold on to the power and home button, till the screen is black, the apple logo comes back, and i let go. after 5mins, my computer makes a chime. itunes recognizes the ipod, but its still on the apple screen. (last time i did this, it showed the charging screen)
    so is there a way to fix this?
    its a ipod touch 3g, 3.1.3 firmware, and its jailbroken. (i really want this fixed since its less then 2 weeks old)
  2. aaa2260 thread starter macrumors newbie

    Aug 24, 2010
    apple doesnt allow you to restore ipod with 3.1.3 firmware, and i dont think you could downgrade to 3.1.2 on a 32gb
  3. celticpride678

    Feb 15, 2009
    Boston, MA
    So, upgrade to iOS 4...
  4. aaa2260 thread starter macrumors newbie

    Aug 24, 2010
    i dont want to upgrade to 4, since i will be using spirit to jailbreak it again, and t only works with 3.2, 3.1.3, and 3.1.2

    edit: tried upgrading, and it still said that its not eligible for the requested build

Share This Page