iPod touch headphone mic doesn't work

Discussion in 'iPod touch Accessories' started by 213rules, Jan 10, 2010.

  1. 213rules macrumors member

    Oct 17, 2008
    I got some new headphones today, with mic feature, and I loaded up the voice memos app to test them out (2 gen btw). I connected it, and it told me to connect a mic, which I did. The sound worked fine, but the iPod wasn't sensing the mic.

    Then, I looked online, and it said to clean out the jack from lint. I spent like 10 minutes trying to extract something with a toothpick, and there was nothing in there. I then got my bud's headphones, and some how the mic worked on them. I put my phones back in, and it still didn't work.

    But for some reason, my headphones mic worked on my bud's iPod. So the headphones aren't messed up, and neither is my ipod. Is something wrong here?
  2. lelisa13p macrumors 68000


    Mar 6, 2009
    Atlanta, GA USA
    Did you push the plug all the way in until the rubber connector is flush against the body of the Touch and you feel a click when it's in all the way?

Share This Page