Ipod touch is malfunctioning.

Discussion in 'iPod touch' started by kozay, Jan 16, 2009.

  1. kozay macrumors newbie

    Jan 16, 2009
    Recently, I plugged in my Ipod touch into my Imac to update some songs, Itunes was already open and nothing. My ipod didn't show up or mount or whatever. I resetted the Ipod, and even tried DFU. Still when I did the DFU Mode, Itunes said ,"Could not restore Ipod" When I simply tried to just restore my iPod (the hold sleep and home screen until apple logo shows then hold home screen) and it would show on Itunes saying "Has detected an ipod in recovery mode" then when I click restore, it goes away and my Ipod disappears, then I restart my iPod and my old media was restored onto my Ipod.

    I have the latest Itunes (8.0.2) and alot of times it says "Cannot connect to Iphone" and its not an IPHONE at all. I've tried plugging the usb into my keyboard, and the back of the Imac.

    Could it be that I'm not using the white USB that came with the Ipod?

    Any advice on how to fix this?
  2. iOrlando macrumors 68000

    Jul 20, 2008
    all i know is dont use keyboard slot... use the cord that came with it as well...

    if all else fails...apple store is a must.
  3. canadagrad macrumors newbie

    Nov 10, 2007
    I wish I could be more help, but I have encountered something kind of similar in that itunes will go on and off with recognizing my iPT and then booting it off, or telling me to restore it, but then it starts synching it and then boots me off again. Today it kept recognizing it as an iphone as well.

    I chalk this up to the wonderful world of windoze quirks, since that's what I'm using, but I wonder why this is happening?
  4. kozay thread starter macrumors newbie

    Jan 16, 2009
    Thanks anyways.

    It keeps giving me Error 1611.
    I really really need a way to fix this problem because I live on Guam, so there is no Apple Store. Just electronic stores that sell apple products.

Share This Page