Ipod touch issues.

Discussion in 'iPod touch' started by remorce, Jan 24, 2009.

  1. remorce macrumors newbie

    Joined:
    Dec 26, 2008
    #1
    Something odd has happened. After downloading some updates from apps i went and played around with the ipod. Accidently hit the itunes store and when I tried to get out of it by pressing the home button nothing happened. I hit it again about 3 minutes later and the music control popped up. I go to press the power button to see if it will work. It did, put it into sleep ( I assume thats what it is) and i clicked it again and I came to the unlock screen, unlocked tried to use the home button again to no avail. So I go to turn it off and I hold down the power button. Nothing happens. Now I am running the battery until it runs out of power so I can charge it and turn it back on when its drained.

    Am I doing the right thing by trying to shut it off by running the battery down? Any Ideas of what just happened to my Ipod Touch?
    :confused::confused::confused:


    *EDIT* Fixed it by doing a restart. Anybody know why this happens though?
     
  2. mgguy macrumors 6502

    mgguy

    Joined:
    Dec 26, 2006
    #2
    From what I've read on MR, it's not that uncommon. I've had it happen once myself. Did a restart and things have been fine ever since. Probably not a sign that the device is bad.
     

Share This Page