ipod touch jailbreak post-problem

Discussion in 'iPod touch' started by bloody, Oct 12, 2007.

  1. bloody macrumors member

    Joined:
    Sep 16, 2007
    #1
    After i jail-breaked my touch, i put some apps on it and stuff. So when i finally tried to sync back my songs and movies after i jailbreaked it, it said The software required for iPhone is not installed. Run the iTunes installer to remove iTunes, then install iTunes again. I tried doing that no luck, i tried forcing it to restore, but it would never get off the sync to iTunes image, unless i waited too shortly. I cant restore cause i cant sync to iTunes. Can someone help me?:confused:

    i used this http://forums.macrumors.com/showthread.php?t=367253
     
  2. match311 macrumors member

    Joined:
    Jun 16, 2007
    #2
    My roommate just jailbreaked his touch and is having the same problem. He is on a PC. But get this, we plug his touch into my macbook pro and all is well. I know this doesn't help much but it should be reassuring that its not fully broken or anything.
     
  3. parrotheadmjb macrumors 6502

    Joined:
    Mar 4, 2007
    #3
    did you put the itunesmobiledevice.dll back? this happens if you dont replace that file when you are done with it
     
  4. match311 macrumors member

    Joined:
    Jun 16, 2007
    #4
    Ok, we just fixed it. We uninstalled itunes and the "apple mobile devices support" in control panel. Then reinstalled itunes from apple's site, and it works.
     

Share This Page