iPod touch not showing photos in iPhoto

Discussion in 'Mac Apps and Mac App Store' started by lana-lang, Aug 12, 2009.

  1. lana-lang macrumors newbie

    Joined:
    Apr 1, 2009
    #1
    I synced some photos onto my iPod touch and now I want to remove some of them from my iPod. But when I click on my iPod under "Devices" in iPhoto, the photos/albums don't show up. It even says, "no photos" at the bottom of the screen!

    What is going on here?
     
  2. skybolt macrumors 6502a

    Joined:
    Feb 20, 2005
    Location:
    Nashville, TN, USA
    #2
    With your iPod connected, and iTunes open, have you gone to the photo tab there (on your iPod) to select which photos to sync? That is where I tell mine what I want it to sync.
     
  3. lana-lang thread starter macrumors newbie

    Joined:
    Apr 1, 2009
    #3
    I did that

    that's how I got the photo albums onto my ipod, but I can't figure out how to delete them! They won't show up in iPhoto.
     
  4. mrkgoo macrumors 65816

    Joined:
    Aug 18, 2005
    #4
    You're not listening.

    iTUNES. All syncing to the device is controlled through iTunes.

    Not iPhoto. iPhoto is only used to import photos taken with the iPod (in this case, images saved) onto your computer. It will never show albums on your device.

    Yes, it's unintuitive and perhaps even stupid (actually, it's not that stupid - the point is that iTunes is the syncing program - not everyone uses iPhoto).

    In conclusion, go to iTunes, select the photos tab, and deselect any album you don't want to sync there.
     
  5. lana-lang thread starter macrumors newbie

    Joined:
    Apr 1, 2009
    #5
    so, let me get this straight...

    ... In order to delete an album from my iPod, I have to delete the album from my iPhoto first and then re-sync? What if I want to keep the photos in iPhoto, but just delete them from my iPod? (limited space on the iPod) There has to be a way to do that, right?

    I'm sorry if I'm asking dumb questions, I'm new to all of this.
     
  6. nparmelee macrumors 6502

    Joined:
    Jan 23, 2008
    #6
    In iTunes, select your iPod. Then select the different tabs and you can turn on and off what syncs to the iPod. For photo albums you select which albums you want on your iPod from the Photos tab. When you are done and sync, you should only see the albums you selected.
     
  7. lana-lang thread starter macrumors newbie

    Joined:
    Apr 1, 2009
    #7
    ahhhh...

    I see what the problem is now.

    I needed to create albums under the Albums menu in iPhoto first! duh. My iTunes wasn't showing anything under "selected albums" that's why I was confused.

    thanks guys.
     

Share This Page