iPod Touch not sorting tv shows

Discussion in 'iPod touch' started by Laimbeersux, Mar 2, 2011.

  1. Laimbeersux macrumors 6502

    Joined:
    Aug 30, 2010
    #1
    Hey all, I am a former iPhone user that left AT&T for Verizon when AT&T killed my ability to use data off-network. I loved my iPhone 4, but having a smartphone that couldn't be used other than to make calls and texts in 95% of the places I live and work just didn't make sense so I went over to the Droid side of things. After playing with a 4th Generation iPod Touch over last weekend, I started looking around at finding good deals on them. I ended up buying one from a buddy of mine who used it until he got the Verizon iPhone 4, and wanted to sell the iPod touch because it didn't make sense to have both to him.

    Introductions aside, after setting up and syncing the new toy, I'm having a few issues with the video app. I have 2 seasons of Sons of Anarchy, one of Afro Samurai, and one of Eastbound and Down that I wanted to put on the iPod, and had plenty of room for. All of them appeared to sync correctly, but then I went into the video app and saw that they were all grouped as episodes of Sons of Anarchy, and the seasons weren't even separated. All of the episodes of all of the shows are grouped together.

    Before you suggest it, I already went into iTunes and made sure each show's information was correct (Show name, season #, and episode #,) then I resynced all of the episodes one season at a time. Still nothing, still the same lack of sorting. I'm pulling my hair out at this point and have no idea why it would do this on the iPod when it sorted them just fine on my old iPhone 4.

    I would really appreciate any input into what I'm possibly doing wrong so I can rectify the situation, since at this point it's a jumbled mess and I couldn't figure out which episode is next without looking it up on imdb. The other thing I tried after a quick Google search was to make playlists with the episodes in order. The playlists however don't show up when I click on the iPod in iTunes, so I have no clue how to select them so they will sync, they also don't show up on the iPod itself. Any ideas? I think I'm probably just missing one check box, or one sorting option.

    Another annoyance is that the iPod seems to freeze about half of the time when I open the Videos app, no rhyme or reason why, I haven't figured out the pattern yet. Help on this issue would be greatly appreciated as well.


    :confused:
     
  2. Laimbeersux thread starter macrumors 6502

    Joined:
    Aug 30, 2010
    #2
    OK, turns out the tv shows weren't sorted correctly on my iPad either, fiddling with it more and more and googling it some more led me to a strange realization from somebody on the Apple Support forums.

    A direct quote from a user named "Nyxolno" is as follows and it seems to have fixed my issue.

    "iOS 4.2 does NOT read the "TV Show" tag. It reads the "Artist" tag for the show title.

    If you put the name of the TV show in the "Artist" field, it will sort them correctly.

    Also, episode numbers are now derived from the "Track" field, instead of the episode number (like it SHOULD)

    If you have an episode that is the sixth episode, you should put "6" in the track field. "

    Anybody know why exactly apple did this? instead of using the episode field from get info to determine what episode it is, they use the track number? Wtf? And they use the Album name to determine what season of what show it is?
     
  3. racheldeet macrumors newbie

    Joined:
    Dec 12, 2010
    #3
    Is this only in 4.2? Because 4.2.1 is reading my TV and Episode tags just fine on both my iPad and iPod.
     
  4. Laimbeersux thread starter macrumors 6502

    Joined:
    Aug 30, 2010
    #4
    It might just be because they are episodes of shows that i ripped off my existing dvd collection so i could have them on my ipad and not have to lug around boxes of dvds. I was then forced to tag everything myself instead of iTunes doing it for me, so I didn't know about the weird labeling convention. I am on 4.2.1 on my iPod touch and iPad, so it was just the source of the video i bet, no clue really but this seems to have fixed my problem.
     

Share This Page