Ipod touch screwed.

Discussion in 'iPod touch' started by kozay, Jan 27, 2009.

  1. kozay macrumors newbie

    Joined:
    Jan 16, 2009
    #1
    Ok, so today I continued to try and resolve my issue with the ipod touch not connecting to Itunes, and the "itunes has detected an Ipod in recovery mode. You must restore this iPod before it can be used with iTunes" then the whole Ipod dismounting before I could even click restore...then all of a sudden, the screen showing the usb connecting to itunes logo just disappeared and the screen flashed sort of a grey-ish-yellow screen and thats it. When I try to reboot the iPod, it just shows this blank grey screen again.

    PLEASE HELP!
     
  2. dubhe macrumors 65816

    dubhe

    Joined:
    May 1, 2007
    Location:
    Norwich, UK
    #2
    hold down the standby switch until it reboots?
     
  3. irene1975y macrumors newbie

    Joined:
    Jan 26, 2009
    #3
    are u using the correct version of itunes with iphone firmware?

    itunes 8.0 -> firmware 2.1, 2.2
    itunes 7.04 below -> 2.0 and below
     
  4. Pgohlke macrumors 6502

    Joined:
    Jan 9, 2009
    Location:
    Centerville, Ohio
    #4
    If you still can't get it to work I would suggest taking it to an apple store and see what they can do for you.
     
  5. X whip X macrumors newbie

    X whip X

    Joined:
    Jan 27, 2009
    #5
    That's a tough one,

    Mine did the exact thing, it most likely did that because of the following reason.

    -You Attempted to jailbreak your i-pod touch so it locked itself.

    Try to do this:
    Go into your i-tunes, and if it still says that click "OK" and click restore,
    Then just let it do it's own thing, And that should probably work, It worked for me anyways, And it worked in under.. I'd say 40 minutes?
     

Share This Page