ipod Touch software update (2.2)

Discussion in 'iPod touch' started by themaster1dz, Nov 24, 2008.

  1. themaster1dz macrumors newbie

    Joined:
    Nov 24, 2008
    #1
    Hi all,

    I'm new here, i hope you can help me. I tried to update my ipod touch (8 GB) software from 2.1 to 2.2...everything works fine till it reaches 70~75% and it stops...

    I tried to restore the whole thing...and now it's trying to restore it (lost music videos and all that stuff but not a problem...), but still same thing, it gets stuck just like with the update at around 70~75% of the restore process !!!


    Is there a way to manually format and install the os or not?

    Thanks for the help.
     
  2. mackmgg macrumors 65816

    mackmgg

    Joined:
    Nov 2, 2007
    #2
    google ipod touch DFU mode and try that. if that doesnt work idk
     
  3. broncopde macrumors 6502

    Joined:
    May 12, 2007
    Location:
    Conway, AR
    #3
    Wirelessly posted (iPod touch: Mozilla/5.0 (iPod; U; CPU iPhone OS 2_2 like Mac OS X; en-us) AppleWebKit/525.18.1 (KHTML, like Gecko) Version/3.1.1 Mobile/5G77 Safari/525.20)

    Are you using a mac or a pc?
     
  4. themaster1dz thread starter macrumors newbie

    Joined:
    Nov 24, 2008
    #4
    I am using a pc with the latest version of itunes. I will try the DFU mode like you suggested mackmgg and see how it goes lol............


    Thanks.
     
  5. themaster1dz thread starter macrumors newbie

    Joined:
    Nov 24, 2008
    #5
    Nope doesn't work...i tried everything...followed step by step...tried 2.2 again...(dunno where to get 2.1)...did it 100 times...always same thing...says "Restoring ipod software" and gets stuck...i'm really starting to lose patience...

    Any idea plz?
     

Share This Page