iPod touch stuck at Apple logo/low battery logo!

Discussion in 'iPod touch' started by Blackbean28, Apr 9, 2012.

  1. Blackbean28, Apr 9, 2012
    Last edited: Apr 9, 2012

    Blackbean28 macrumors newbie

    Apr 9, 2012
    Well, about a year ago, my iPod touch USB cable broke, and only recently have I decided to buy a new one. I knew that the last time I used my iPod, I ran the battery down to empty, so I attempted to charge it as soon as I got the USB cable home. But, when it started up, it just kept cycling through the low battery and Apple logo over and over again. It is jailbroken, and iTunes wont recognize it when I plug it into my computer, but I can't remember what I could have done last time I went on it that could have made it do this. I'm really stuck, so PLEASE can someone give me a solution. Thanks in advance.

  2. flashyman macrumors member

    Apr 9, 2012
    there may have problem with your new cable. you can try another cable.
  3. yanksrock100 macrumors 6502a


    Oct 30, 2010
    San Diego
    I agree, try a new cable. This happened to me with my iPod cable, so I just switched cables, and it worked like a charm :)
  4. Willyb26 macrumors member


    Nov 1, 2011
    Yea also what type of jailbreak was it? Tethered/untethered

Share This Page