Ipod Touch stuck on apple logo

Discussion in 'iPod touch' started by dancer09, Jun 26, 2009.

  1. dancer09 macrumors newbie

    Joined:
    Jun 26, 2009
    #1
    Ok...my ipod touch is stuck on the apple logo and all it shows is that and a little spinning gear. My computer reads the ipod in itunes, shows that all the music is there and charges just fine, it shows that the ipod is functioning but i can't get the screen to come back...I have tried the holding down the hold and menu button, and I have tried completly restoring it like 5 times...when I restore the itunes logo and the USB cord show up on the ipod screen but when I am done doing the restore it goes right back to the apple logo and the spinning gear. I think I have tried all the troubleshooting tips on the apple website and nothing is helping. Does anyone have any idea how to help me without me having to spend hundreds of dollars. Thanks:eek: ]
     
  2. nateo200 macrumors 68030

    nateo200

    Joined:
    Feb 4, 2009
    Location:
    Northern District NY
    #2
    Just happened to me, don't even bother go to the apple website aNd schedule an appointment with the genius at the store ASAP. They were great for me and practically pounced on me asking if I needed help.
     

Share This Page