iPod Touch totally bricked?

Discussion in 'iPod touch' started by xafakasix, May 7, 2011.

  1. xafakasix macrumors newbie

    Joined:
    May 7, 2011
    #1
    Alright so my itouch wasnt connecting to my computer at all, it kept getting 'USB device not recognized' so i tried Recovery mode and DFU mode and still not recognized. So i decided to reset it from the settings, I did the reset and delete everything. So this is where i am now, when i try to turn it on the apple logo with a little loading sign comes up for like 10 min then it turns off and back on then the logo reappears followed by the loading sign again. Since this has happened i have tried recovery and DFU mode again and on 3 computers and wth 3 different cable on each computer. I'm pretty stuck, if anyone has any clue on how to fix this or any ideas I'd be happy to see some answers, and my ipod touch was jailbroken and has 4.1 software
     
  2. risingup macrumors newbie

    Joined:
    Apr 26, 2011
    Location:
    India
  3. MaxBurn macrumors 65816

    MaxBurn

    Joined:
    Nov 25, 2010
    #3
    Yup, seems like you want to go to the apple store and exchange it.
     
  4. xafakasix thread starter macrumors newbie

    Joined:
    May 7, 2011
    #4
    but it was jailbroken, wont they be able to tell
     
  5. jessieblack98 macrumors newbie

    Joined:
    Jun 21, 2011
    #5
    bricked ipod touch

    dude ur ipod touch is bricked and totally useless
     
  6. AdrianK macrumors 68020

    Joined:
    Feb 19, 2011
    #6
    Yes, if they can actually mount the filesystem, but if the damn thing doesn't boot I don't see how they could :p

    Will they check? Probably not. Will they care? Probably not?

    There's nothing you can do with the device anyway, might as well try.
     

Share This Page