iPod Touch "virus" issue

Discussion in 'iPod touch' started by slomifier, Jan 21, 2010.

  1. slomifier macrumors regular

    Joined:
    Mar 25, 2008
    #1
    First of all, my iPod is a 32gb, 3g iPod Touch, Jailbroken
    Now that thats out of the way, my problem:
    This morning when I went out for breakfast, I used my ipod to listen to music, and it worked fine. When I got home, I went onto cydia and downloaded Categories and iFile, then put my ipod down.
    When I went to work about an hour later, I tried using the headphone remote to start the music (the one with the pause/play and volume buttons; and a mic), and nothing happened. So, i went into the ipod app manually and started it, and music began playing out of the speaker and the headphones at the same time. (and what was coming out of the headphones was too loud to listen to, even at the lowest volume). I resprang it, but that didnt help. I know that its not a hardware issue, because this has happened before, and restoring it fixed the problem. Restoring is a major pain though. Does anyone know what might have caused this, or how to fix it without restoring?
    Thanks
     
  2. elpmas macrumors 68000

    elpmas

    Joined:
    Sep 9, 2009
    Location:
    Where the fresh snow don't go.
    #2
    wth lol. that's whack....i dont think it's a virus...
     
  3. slomifier thread starter macrumors regular

    Joined:
    Mar 25, 2008
    #3
    -_-

    Id also like to add that the other time it happened, it hadn't just installed Categories or iFile, so I don't think it has to do with the apps themselves
     
  4. MasterDev macrumors 65816

    Joined:
    Sep 14, 2009
    #4
    That's why you shouldn't jailbreak your iPhone.
     
  5. chrono1081 macrumors 604

    chrono1081

    Joined:
    Jan 26, 2008
    Location:
    Isla Nublar
    #5
    +1

    Also I doubt its a virus. Despite what Hollywood movies show most of the times people have a virus they have no clue about it. Malware writers usually want something specific so they make sure that their "app" is never detected so it can keep stealing credit card numbers, downloading illegal porn to your computer that others can access, etc.
     
  6. pcs are junk macrumors 65816

    Joined:
    Sep 28, 2009
    #6
    try resetting settings? sometimes fixes it for me. sounds like you downloaded something with bad coding, (not intentionally malicious), but that it caused ur ipod to play through both, so in a way ur ipod got confused. so try resetting settings, and next time dont give ur ipod chlamydia.
     
  7. Slopi macrumors newbie

    Joined:
    Jan 22, 2010
    #7
    I'm not sure what makes you think this is a virus? Sounds like a common issue between programs or dependencies in the OS. Certainly doesn't warrent crying wolf over OMG VIRRIIS!!

    And the reason is? Jailbreak caused this how? Care to explain why you fear jailbreaking beyond mythical notions of a ruined device?
     
  8. gibbz macrumors 68030

    Joined:
    May 31, 2007
    #8
    Jailbroken phones are more unstable than official Apple releases, which isn't even arguable.
     
  9. appleguy123 macrumors 603

    appleguy123

    Joined:
    Apr 1, 2009
    Location:
    15 minutes in the future
    #9
    Jailbroken phones are more functional than official Apple Releases, which isn't even arguable.
     
  10. gibbz macrumors 68030

    Joined:
    May 31, 2007
    #10
    Function doesn't mean anything if said function doesn't work correctly (see OP)
     
  11. instaxgirl macrumors 65816

    instaxgirl

    Joined:
    Mar 11, 2009
    Location:
    Edinburgh, UK
    #11
    Back up and reset all settings. If nothing changes restore it. If the problem persists then you'll have to go to Apple.

    If the problem's gone jailbreak again and install one app at a time checking the iPod after each install.. If problem persists then restore and either don't add the problem app or don't jailbreak again until the new version appears.

    Tbh I think the iPod's just having a messed up moment, I've never experienced anything as a direct result of jailbreaking but iPods and iPhones do spazz out occasionally (technical term :p)

    Since you've got the extra factor of jailbreak you'll have to check that's not the cause, but I'm sure a restore'll fix it.
     
  12. ETID macrumors regular

    Joined:
    Jan 6, 2008
    #12
    Funnily enough my 3g did that on the day after i got it. I didn't jailbreak it or anything so it must have just been a little fault. I managed to fix mine by just unplugging the headphones and putting them back in.
     
  13. slomifier thread starter macrumors regular

    Joined:
    Mar 25, 2008
    #13
    Hate to take sides, but Id rather risk a temp instability than live with the half-ass stuff thats included in the firmware

    Anyways :). Has anyone else found anything weird after installing iFile, Categories or any of the other major cydia/rock apps?

    And does anyone know if I can scan my ipod for viruses somehow?
    Is there a way to do it through my laptop (Avast!), or would it even pick up a foreign platform virus

    Thanks
     
  14. slomifier thread starter macrumors regular

    Joined:
    Mar 25, 2008
    #14
    SOLVED! (Maybe)

    If anyone else is having this problem, I think I know what it is.

    It happened again, right after I tried downloading Crackulous through cydia, and realized that everytime I got this glitch, it was after trying to install Crackulous. Idk if Crackulous is infected, or has a malfunction in it, but that seems to be the issue

    Thanks
     
  15. -AG- macrumors regular

    -AG-

    Joined:
    Jan 24, 2010
    Location:
    Austalia
    #15
    Did you happen to do a reset after you finished downloading the app?

    Because by the sounds of it its the cyndia apps that are not installing completely until the device has been given a proper reboot.

    oh yeah ....jailbreaking is bad mmmkay :p
     
  16. soarer123 macrumors newbie

    Joined:
    Mar 25, 2009
    #16
    seems like i have a similar problem, i installed dark nebula on my touch and didnt use it for a day, and when i turned it on, bookworm started like it was on automatic mode and started playing by itself..., lousy speller by the way...
    also dark nebula seemes a little unstable.

    any clues ?
     
  17. slu macrumors 68000

    slu

    Joined:
    Sep 15, 2004
    Location:
    Buffalo
    #17
    I have no problem with jailbreaking. I had my iPhone jailbroken for a while. I do have a problem with people who pirate apps. Stop being a cheapskate. You deserve any instability you get for pirating apps. Grow up and pay for the apps you use that are available from the app store.

    If you can afford all the toys in your sig, you can afford to pay a dollar or two for apps.
     
  18. Vesuvio Cat macrumors regular

    Joined:
    Jan 30, 2010
    #18
    The more important question is: why do you need three iPod Touches?
     
  19. slomifier thread starter macrumors regular

    Joined:
    Mar 25, 2008
    #19
    Lol, I don't, I sold them. I need to take them down.
    Anyways, I solved it, and this time I experimented and found out for sure what it is.
    Sorry that this is a big bump, but if someone is looking for this problem, heres the solution

    The problem is Insomnia. If I restart/respring my iPod with Insomnia enabled and my headphones are plugged in, I get the problem.

    If anyone else ever has this problem, do this:
    -Unplug headphones and disconnect all BT peripherals
    -Disable and completely uninstall Insomnia (You must disable first, and dont use CyDelete for this. Use the Repository App)
    -Restart your iPod. Dont just respring. Yes, on a 3g, you'll have to do a tethered reboot.
    -Should be fixed now :)

    Hope that helped
     
  20. mike.coulter macrumors regular

    mike.coulter

    Joined:
    Jun 10, 2008
    Location:
    Cardiff
    #20
    I would suppose that it's just a bug in the systems firmware. Mainly because a restore fixed it. Meaning it can't just be a hardware problem.
     

Share This Page